On 28/5/22 11:19, Mark Cave-Ayland wrote:
Whilst reviewing Bernhard's PIIX Southbridge QOMifcation patches at
https://lists.gnu.org/archive/html/qemu-devel/2022-05/msg04329.html, I
noticed that we should first eliminate the legacy device init function
piix4_pm_init().
This series moves the outstanding logic from piix4_pm_init() into the
relevant instance init() and realize() functions, changes the IRQs to
use qdev gpios, and then finally removes the now-unused piix4_pm_initfn()
function.
Signed-off-by: Mark Cave-Ayland <mark.cave-ayl...@ilande.co.uk>
Mark Cave-Ayland (12):
hw/acpi/piix4: move xen_enabled() logic from piix4_pm_init() to
piix4_pm_realize()
hw/acpi/piix4: change smm_enabled from int to bool
hw/acpi/piix4: convert smm_enabled bool to qdev property
hw/acpi/piix4: move PIIX4PMState into separate piix4.h header
hw/acpi/piix4: alter piix4_pm_init() to return PIIX4PMState
hw/acpi/piix4: rename piix4_pm_init() to piix4_pm_initfn()
hw/acpi/piix4: introduce piix4_pm_init() instance init function
hw/acpi/piix4: use qdev gpio to wire up sci_irq
hw/acpi/piix4: use qdev gpio to wire up smi_irq
hw/i386/pc_piix: create PIIX4_PM device directly instead of using
piix4_pm_initfn()
hw/isa/piix4.c: create PIIX4_PM device directly instead of using
piix4_pm_initfn()
hw/acpi/piix4: remove unused piix4_pm_initfn() function
Nitpicking, SCI could also be a named GPIO :)
Series:
Reviewed-by: Philippe Mathieu-Daudé <f4...@amsat.org>