On 4/13/22 14:25, Eric Blake wrote:
-static bool nbd_recv_coroutine_wake_one(NBDClientRequest *req)
+static bool coroutine_fn nbd_recv_coroutine_wake_one(NBDClientRequest *req)
This already has_coroutine_ in the name, would it be better as_co_?
{
if (req->receiving) {
req->receiving = false;
@@ -144,7 +144,7 @@ static bool nbd_recv_coroutine_wake_one(NBDClientRequest
*req)
return false;
}
-static void nbd_recv_coroutines_wake(BDRVNBDState *s, bool all)
+static void coroutine_fn nbd_recv_coroutines_wake(BDRVNBDState *s, bool all)
This already has_coroutines_ in the name, would it be better as_co_?
These mean "wake a coroutine", not "I'm in a coroutine", so I'd say they
are fine as is.
Paolo