On 12/24/21 07:49, Peter Xu wrote: > It'll be easier to read the name rather than index of sub-cmd when debugging. > > Signed-off-by: Peter Xu <pet...@redhat.com> > --- > migration/savevm.c | 3 ++- > migration/trace-events | 2 +- > 2 files changed, 3 insertions(+), 2 deletions(-)
> diff --git a/migration/trace-events b/migration/trace-events > index b48d873b8a..d63a5915f5 100644 > --- a/migration/trace-events > +++ b/migration/trace-events > @@ -22,7 +22,7 @@ loadvm_postcopy_handle_resume(void) "" > loadvm_postcopy_ram_handle_discard(void) "" > loadvm_postcopy_ram_handle_discard_end(void) "" > loadvm_postcopy_ram_handle_discard_header(const char *ramid, uint16_t len) > "%s: %ud" > -loadvm_process_command(uint16_t com, uint16_t len) "com=0x%x len=%d" > +loadvm_process_command(const char *s, uint16_t len) "com=%s len=%d" Also: len=%u Otherwise: Reviewed-by: Philippe Mathieu-Daudé <phi...@redhat.com>