On 12/18/21 03:07, Richard Henderson wrote: > On 12/17/21 3:18 PM, Philippe Mathieu-Daudé wrote: >>>> #define MEMTX_OK 0 >>>> #define MEMTX_ERROR (1U << 0) /* device returned an >>>> error */ >>>> #define MEMTX_DECODE_ERROR (1U << 1) /* nothing at that >>>> address */ >>>> +#define MEMTX_BUS_ERROR (1U << 2) /* bus returned an error */ >>> >>> This is kind of odd naming, because MEMTX_DECODE_ERROR already means >>> "bus/interconnect returned an error" and it generally translates >>> into what at the OS level gets called a "bus error"... >> >> MEMTX_DECODE_ERROR is "nothing at that address". We want a name >> for "there is something, but you don't have access to it". >> Maybe MEMTX_ILLEGAL_ERROR? > > ILLEGAL doesn't convey much. MEMTX_ACCESS_ERROR?
OK, such: #define MEMTX_ACCESS_ERROR (1U << 2) /* access denied */ alternatively MEMTX_PERM_ERROR.