On Mon, Jul 19, 2021 at 06:48:15PM +0200, Andrew Jones wrote:
> On Mon, Jul 19, 2021 at 05:36:39PM +0100, Daniel P. Berrangé wrote:
> > On Mon, Jul 19, 2021 at 06:28:46PM +0200, Andrew Jones wrote:
> > > On Mon, Jul 19, 2021 at 11:20:34AM +0800, Yanan Wang wrote:
> > > > Currently the only difference between smp_parse and pc_smp_parse
> > > > is the support of multi-dies and the related error reporting code.
> > > > With an arch compat variable "bool smp_dies_supported", we can
> > > > easily make smp_parse generic enough for all arches and the PC
> > > > specific one can be removed.
> > > > 
> > > > Making smp_parse() generic enough can reduce code duplication and
> > > > ease the code maintenance, and also allows extending the topology
> > > > with more arch specific members (e.g., clusters) in the future.
> > > > 
> > > > No functional change intended.
> > > > 
> > > > Suggested-by: Andrew Jones <drjo...@redhat.com>
> > > > Signed-off-by: Yanan Wang <wangyana...@huawei.com>
> > > > ---
> > > >  hw/core/machine.c   | 28 ++++++++++-------
> > > >  hw/i386/pc.c        | 76 +--------------------------------------------
> > > >  include/hw/boards.h |  1 +
> > > >  3 files changed, 19 insertions(+), 86 deletions(-)
> > > > 
> > > > diff --git a/hw/core/machine.c b/hw/core/machine.c
> > > > index d73daa10f4..ed6712e964 100644
> > > > --- a/hw/core/machine.c
> > > > +++ b/hw/core/machine.c
> > > > @@ -743,6 +743,7 @@ void machine_set_cpu_numa_node(MachineState 
> > > > *machine,
> > > >  
> > > >  static void smp_parse(MachineState *ms, SMPConfiguration *config, 
> > > > Error **errp)
> > > >  {
> > > > +    MachineClass *mc = MACHINE_GET_CLASS(ms);
> > > >      unsigned cpus    = config->has_cpus ? config->cpus : 0;
> > > >      unsigned sockets = config->has_sockets ? config->sockets : 0;
> > > >      unsigned dies    = config->has_dies ? config->dies : 1;
> > > > @@ -761,7 +762,7 @@ static void smp_parse(MachineState *ms, 
> > > > SMPConfiguration *config, Error **errp)
> > > >          return;
> > > >      }
> > > >  
> > > > -    if (dies > 1) {
> > > > +    if (!mc->smp_dies_supported && dies > 1) {
> > > 
> > > Won't this allow a user on an arch with !mc->smp_dies_supported to specify
> > > dies=1?
> > 
> > Conceptually that is fine. Before the introduction of CPU sockets
> > with 2+ dies, you can credibly say that all sockets had 1 die, so
> > it is nreasonable for users to say -smp ....,dies=1,....
> > 
> > libvirt will unconditionally set dies=1 for all QEMU targets if
> > the user didn't specify an explicit dies value
> > 
> > >          To not allow that, can we do
> > > 
> > >    if (!mc->smp_dies_supported && config->has_dies)
> > > 
> > > instead?
> > 
> > I don't see that this is benefitting apps/users.
> 
> Other than maintaining consistency; erroring with "we don't support dies"
> for 2+, but not for 1, is inconsistent, then I agree there isn't much
> reason to disallow it, since we'll be using the value of 1 anyway
> internally. I don't really have a strong preference here, so I'm fine with
> allowing dies=1.

How about we tweak the error message from

  "dies not supported by this machine's CPU topology"

to

  "multiple dies not supported by this machine's CPU topology"


Regards,
Daniel
-- 
|: https://berrange.com      -o-    https://www.flickr.com/photos/dberrange :|
|: https://libvirt.org         -o-            https://fstop138.berrange.com :|
|: https://entangle-photo.org    -o-    https://www.instagram.com/dberrange :|


Reply via email to