On 7/4/21 7:31 AM, Liren Wei wrote:
-static gint tb_tc_cmp(gconstpointer ap, gconstpointer bp)
+static gint tb_tc_cmp(gconstpointer ap, gconstpointer bp, gpointer _)
Using _ here as the variable name isn't ideal. I guess if this were c++ we would actually
omit the name, which is kinda the same. But I think it's just as easy to name it
userdata, as per glib docs.
I'll fix that up while queuing, thanks.
I'm not keen that the spinlock init and destroy are in different places, but surely that
should be fixed by moving the init to tcg_tb_alloc, probably moving it to tcg/region.c as
well.
r~