On 6/29/21 6:36 AM, Peter Maydell wrote:
A little way up from here there's a comment:
/* Reserve space for the return code. On a real system this would
* be within the VDSO. So, despite the name this is not a "real"
* record within the frame.
*/
fr_ofs = layout.total_size;
layout.total_size += sizeof(struct target_rt_frame_record);
That now needs updating, because we're no longer putting the return
code in that target_rt_frame_record.
Updated to
/*
* Reserve space for the standard frame unwind pair: fp, lr.
* Despite the name this is not a "real" record within the frame.
*/
I think the 'struct target_rt_frame_record' now does correspond
to the kernel's 'struct frame_record', right?
Yes.
r~