On Fri, Jun 18 2021, Cornelia Huck <coh...@redhat.com> wrote: > On Fri, Jun 18 2021, Eric Farman <far...@linux.ibm.com> wrote: > >> The Interrupt Response Block is comprised of several other >> structures concatenated together, but only the 12-byte >> Subchannel-Status Word (SCSW) is defined as a proper struct. >> Everything else is a simple array of 32-bit words. >> >> Let's define a proper struct for the 20-byte Extended-Status >> Word (ESW) so that we can make good decisions about the sense >> data that would go into the ECW area for virtual vs >> passthrough devices. >> >> Signed-off-by: Eric Farman <far...@linux.ibm.com> >> --- >> hw/s390x/css.c | 19 +++++++++++++------ >> include/hw/s390x/ioinst.h | 12 +++++++++++- >> 2 files changed, 24 insertions(+), 7 deletions(-) >> >> diff --git a/include/hw/s390x/ioinst.h b/include/hw/s390x/ioinst.h >> index c6737a30d4..e7ab401781 100644 >> --- a/include/hw/s390x/ioinst.h >> +++ b/include/hw/s390x/ioinst.h >> @@ -123,10 +123,20 @@ typedef struct SCHIB { >> uint8_t mda[4]; >> } QEMU_PACKED SCHIB; >> >> +/* format-0 extended-status word */ >> +typedef struct ESW { >> + uint32_t word0; >> + uint32_t erw; >> + uint64_t f_addr; /* Zeros for other ESW formats */ >> + uint32_t s_addr; /* Zeros for other ESW formats */ >> +} QEMU_PACKED ESW; > > Eww, this fails with mingw: > https://gitlab.com/cohuck/qemu/-/jobs/1358335494 > > i686-w64-mingw32-gcc -Ilibcommon.fa.p -I../slirp -I../slirp/src > -I../dtc/libfdt -I../capstone/include/capstone -I. -Iqapi -Itrace -Iui > -Iui/shader -I/usr/i686-w64-mingw32/sys-root/mingw/include > -I/usr/i686-w64-mingw32/sys-root/mingw/include/glib-2.0 > -I/usr/i686-w64-mingw32/sys-root/mingw/lib/glib-2.0/include > -I/usr/i686-w64-mingw32/sys-root/mingw/include/gtk-3.0 > -I/usr/i686-w64-mingw32/sys-root/mingw/include/cairo > -I/usr/i686-w64-mingw32/sys-root/mingw/include/pango-1.0 > -I/usr/i686-w64-mingw32/sys-root/mingw/include/fribidi > -I/usr/i686-w64-mingw32/sys-root/mingw/include/harfbuzz > -I/usr/i686-w64-mingw32/sys-root/mingw/include/atk-1.0 > -I/usr/i686-w64-mingw32/sys-root/mingw/include/pixman-1 > -I/usr/i686-w64-mingw32/sys-root/mingw/include/freetype2 > -I/usr/i686-w64-mingw32/sys-root/mingw/include/libpng16 > -I/usr/i686-w64-mingw32/sys-root/mingw/include/gdk-pixbuf-2.0 > -I/usr/i686-w64-mingw32/sys-root/mingw/lib/libffi-3.1/include > -I/usr/i686-w64-mingw32/sys-root/mingw/include/p11-kit-1 > -I/usr/i686-w64-mingw32/sys-root/mingw/include/SDL2 -fdiagnostics-color=auto > -pipe -Wall -Winvalid-pch -Werror -std=gnu99 -O2 -g -iquote . -iquote > /builds/cohuck/qemu -iquote /builds/cohuck/qemu/include -iquote > /builds/cohuck/qemu/disas/libvixl -iquote /builds/cohuck/qemu/tcg/i386 > -mms-bitfields -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -m32 -D_GNU_SOURCE > -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -Wstrict-prototypes > -Wredundant-decls -Wundef -Wwrite-strings -Wmissing-prototypes > -fno-strict-aliasing -fno-common -fwrapv -Wold-style-declaration > -Wold-style-definition -Wtype-limits -Wformat-security -Wformat-y2k > -Winit-self -Wignored-qualifiers -Wempty-body -Wnested-externs -Wendif-labels > -Wexpansion-to-defined -Wimplicit-fallthrough=2 -Wno-missing-include-dirs > -Wno-shift-negative-value -Wno-psabi -fstack-protector-strong -Dmain=SDL_main > -Wno-undef -mms-bitfields -mms-bitfields -mms-bitfields -MD -MQ > libcommon.fa.p/hw_s390x_virtio-ccw-gpu.c.obj -MF > libcommon.fa.p/hw_s390x_virtio-ccw-gpu.c.obj.d -o > libcommon.fa.p/hw_s390x_virtio-ccw-gpu.c.obj -c ../hw/s390x/virtio-ccw-gpu.c > In file included from > /usr/i686-w64-mingw32/sys-root/mingw/include/winsock2.h:54, > from /builds/cohuck/qemu/include/sysemu/os-win32.h:29, > from /builds/cohuck/qemu/include/qemu/osdep.h:135, > from ../hw/s390x/virtio-ccw-gpu.c:11: > /builds/cohuck/qemu/include/hw/s390x/ioinst.h:131:13: error: expected ':', > ',', ';', '}' or '__attribute__' before '.' token > 131 | uint32_t s_addr; /* Zeros for other ESW formats */ > | ^~~~~~
It seems to be the name that is tripping it; if I rename it to sec_addr and the preceding field to fail_addr, the build passes. Anyone know why that is? And if renaming is unavoidable, are fail_addr and sec_addr ok, or can we find better names? > In file included from /builds/cohuck/qemu/include/qemu/osdep.h:37, > from ../hw/s390x/virtio-ccw-gpu.c:11: > /builds/cohuck/qemu/include/qemu/compiler.h:80:36: error: static assertion > failed: "size of IRB is wrong" > 80 | #define QEMU_BUILD_BUG_MSG(x, msg) _Static_assert(!(x), msg) > | ^~~~~~~~~~~~~~ > /builds/cohuck/qemu/include/hw/s390x/ioinst.h:143:1: note: in expansion of > macro 'QEMU_BUILD_BUG_MSG' > 143 | QEMU_BUILD_BUG_MSG(sizeof(IRB) != 96, "size of IRB is wrong"); > | ^~~~~~~~~~~~~~~~~~ > These were just follow-on errors. >> + >> +#define ESW_ERW_SENSE 0x01000000 >> + >> /* interruption response block */ >> typedef struct IRB { >> SCSW scsw; >> - uint32_t esw[5]; >> + ESW esw; >> uint32_t ecw[8]; >> uint32_t emw[8]; >> } IRB;