2011/9/25 Lluís Vilanova <vilan...@ac.upc.edu>: > Blue Swirl writes: >> diff --git a/trace-events b/trace-events >> index a31d9aa..718e0d5 100644 >> --- a/trace-events >> +++ b/trace-events >> @@ -502,3 +502,13 @@ escc_sunkbd_event_in(int ch) "Untranslated keycode >> %2.2x" >> escc_sunkbd_event_out(int ch) "Translated keycode %2.2x" >> escc_kbd_command(int val) "Command %d" >> escc_sunmouse_event(int dx, int dy, int buttons_state) "dx=%d dy=%d >> buttons=%01x" >> + >> +# target-sparc/mmu_helper.c >> +mmu_helper_dfault(uint64_t address, uint64_t context, int mmu_idx, uint32_t >> tl) "DFAULT at %"PRIx64" context %"PRIx64" mmu_idx=%d tl=%d" > > Won't any of these collide with events from other targets?
Not at the moment. > If all targets are going to use the same tracing events, then maybe the header > stating the file should be renamed. Usually the source file name is used as a prefix, but that won't help in all cases (helper.c etc).