On Thu, Sep 03, 2020 at 05:44:29PM +0100, Daniel P. Berrangé wrote: > On Thu, Sep 03, 2020 at 12:18:09PM -0400, Eduardo Habkost wrote: > > On Thu, Sep 03, 2020 at 02:47:03PM +0200, Philippe Mathieu-Daud̮̩ > > wrote: > > > On 9/3/20 12:42 AM, Eduardo Habkost wrote: > > > > This will make the type name constant consistent with the name of > > > > the type checking macro. > > > > > > > > Signed-off-by: Eduardo Habkost <ehabk...@redhat.com> > > > > --- > > > > Cc: "Michael S. Tsirkin" <m...@redhat.com> > > > > Cc: Paolo Bonzini <pbonz...@redhat.com> > > > > Cc: qemu-devel@nongnu.org > > > > --- > > > > include/hw/timer/i8254.h | 4 ++-- > > > > hw/timer/i8254.c | 4 ++-- > > > > 2 files changed, 4 insertions(+), 4 deletions(-) > > > > > > > > diff --git a/include/hw/timer/i8254.h b/include/hw/timer/i8254.h > > > > index 1a522a2457..ddd925074f 100644 > > > > --- a/include/hw/timer/i8254.h > > > > +++ b/include/hw/timer/i8254.h > > > > @@ -45,7 +45,7 @@ typedef struct PITCommonClass PITCommonClass; > > > > DECLARE_OBJ_CHECKERS(PITCommonState, PITCommonClass, > > > > PIT_COMMON, TYPE_PIT_COMMON) > > > > > > > > -#define TYPE_I8254 "isa-pit" > > > > +#define TYPE_PIT "isa-pit" > > > > > > I disagree with this patch, as we have various PIT and only one I8254. > > > > I was unsure about this, and I agree with your point. I will > > suggest renaming the PIT macro to I8254 instead. > > IMHO the macro name should be directly related to the object name > string with non-alnum characters replaced by underscore. > > ie since the object type is "isa-pit", then the macro should be > TYPE_ISA_PIT
I think that's a good idea in this specific case because it's a short name (I will do it). But I don't think we'll be able to always follow that rule, as the QOM type name is user-visible. -- Eduardo