In commit d88c42ff2c we added 2 methods: i2c_try_create_slave() and i2c_realize_and_unref(). Markus noted their name could be improved for consistency [1], and Peter reported the lack of documentation [2]. Fix that now.
Since v1: - Addressed Markus review comments - Added Markus/Corey R-b tags [1] https://lists.gnu.org/archive/html/qemu-devel/2020-06/msg07060.html [2] https://lists.gnu.org/archive/html/qemu-devel/2020-06/msg08997.html $ git backport-diff -u -v1 Key: [----] : patches are identical [####] : number of functional differences between upstream/downstream patch [down] : patch is downstream-only The flags [FC] indicate (F)unctional and (C)ontextual differences, respectively 001/5:[----] [--] 'hw/i2c/aspeed_i2c: Simplify aspeed_i2c_get_bus()' 002/5:[0006] [FC] 'hw/i2c: Rename i2c_try_create_slave() as i2c_slave_new()' 003/5:[0004] [FC] 'hw/i2c: Rename i2c_realize_and_unref() as i2c_slave_realize_and_unref()' 004/5:[0006] [FC] 'hw/i2c: Rename i2c_create_slave() as i2c_slave_create_simple()' 005/5:[0012] [FC] 'hw/i2c: Document the I2C qdev helpers' Philippe Mathieu-Daudé (5): hw/i2c/aspeed_i2c: Simplify aspeed_i2c_get_bus() hw/i2c: Rename i2c_try_create_slave() as i2c_slave_new() hw/i2c: Rename i2c_realize_and_unref() as i2c_slave_realize_and_unref() hw/i2c: Rename i2c_create_slave() as i2c_slave_create_simple() hw/i2c: Document the I2C qdev helpers include/hw/i2c/aspeed_i2c.h | 2 +- include/hw/i2c/i2c.h | 54 ++++++++++++++++++++++-- hw/arm/aspeed.c | 82 +++++++++++++++++++------------------ hw/arm/musicpal.c | 4 +- hw/arm/nseries.c | 8 ++-- hw/arm/pxa2xx.c | 5 ++- hw/arm/realview.c | 2 +- hw/arm/spitz.c | 4 +- hw/arm/stellaris.c | 2 +- hw/arm/tosa.c | 2 +- hw/arm/versatilepb.c | 2 +- hw/arm/vexpress.c | 2 +- hw/arm/z2.c | 4 +- hw/display/sii9022.c | 2 +- hw/i2c/aspeed_i2c.c | 3 +- hw/i2c/core.c | 15 ++++--- hw/ppc/e500.c | 2 +- hw/ppc/sam460ex.c | 2 +- 18 files changed, 123 insertions(+), 74 deletions(-) -- 2.21.3