On Thu, Jul 14, 2011 at 10:37:02AM +0200, Gerd Hoffmann wrote: > On 07/13/11 16:49, Alon Levy wrote: > >Signed-off-by: Alon Levy<al...@redhat.com> > >--- > > hw/qxl.c | 61 > > ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++- > > 1 files changed, 60 insertions(+), 1 deletions(-) > > > >diff --git a/hw/qxl.c b/hw/qxl.c > >index e41f8cc..2ecc932 100644 > >--- a/hw/qxl.c > >+++ b/hw/qxl.c > >@@ -408,6 +408,64 @@ static const char *qxl_mode_to_string(int mode) > > return "INVALID"; > > } > > > >+static const char *io_port_to_string(uint32_t io_port) > >+{ > >+ if (io_port>= QXL_IO_RANGE_SIZE) { > >+ return "out of range"; > >+ } > >+ switch (io_port) { > >+ case QXL_IO_NOTIFY_CMD: > >+ return "QXL_IO_NOTIFY_CMD"; > >+ case QXL_IO_NOTIFY_CURSOR: > >+ return "QXL_IO_NOTIFY_CURSOR"; > > That becomes alot more readable when using a c99 array for it: > > static const char *io_port_names[QXL_IO_RANGE_SIZE] = { > [ QXL_IO_NOTIFY_CMD ] = "notify-cmd", > [ QXL_IO_NOTIFY_CURSOR ] = "notify-cursor", > [ ... ] > }; > >
Fine.