* Kevin Wolf (kw...@redhat.com) wrote: > Am 12.05.2020 um 11:43 hat Daniel P. Berrangé geschrieben: > > On Tue, May 12, 2020 at 11:32:06AM +0200, Lukas Straub wrote: > > > On Mon, 11 May 2020 16:46:45 +0100 > > > "Dr. David Alan Gilbert" <dgilb...@redhat.com> wrote: > > > > > > > * Daniel P. Berrangé (berra...@redhat.com) wrote: > > > > > ... > > > > > That way if QEMU does get stuck, you can start by tearing down the > > > > > least distruptive channel. eg try tearing down the migration > > > > > connection > > > > > first (which shouldn't negatively impact the guest), and only if that > > > > > doesn't work then, move on to tear down the NBD connection (which > > > > > risks > > > > > data loss) > > > > > > > > I wonder if a different way would be to make all network connections > > > > register with yank, but then make yank take a list of connections to > > > > shutdown(2). > > > > > > Good Idea. We could name the connections (/yank callbacks) in the > > > form "nbd:<node-name>", "chardev:<chardev-name>" and "migration" > > > (and add "netdev:...", etc. in the future). Then make yank take a > > > list of connection names as you suggest and silently ignore connections > > > that don't exist. And maybe even add a 'query-yank' oob command returning > > > a list of registered connections so the management application can do > > > pattern matching if it wants. > > I'm generally not a big fan of silently ignoring things. Is there a > specific requirement to do it in this case, or can management > applications be expected to know which connections exist? > > > Yes, that would make the yank command much more flexible in how it can > > be used. > > > > As an alternative to using formatted strings like this, it could be > > modelled more explicitly in QAPI > > > > { 'struct': 'YankChannels', > > 'data': { 'chardev': [ 'string' ], > > 'nbd': ['string'], > > 'migration': bool } } > > > > In this example, 'chardev' would accept a list of chardev IDs which > > have it enabled, 'nbd' would accept a list of block node IDs which > > have it enabled, and migration is a singleton on/off. > > Of course, it also means that the yank code needs to know about every > single object that supports the operation, whereas if you only have > strings, the objects could keep registering their connection with a > generic function like yank_register_function() in this version. > > I'm not sure if the additional complexity is worth the benefits.
I tend to agree; although we do have to ensure we either use an existing naming scheme (e.g. QOM object names?) or make sure we've got a well defined list of prefixes. Dave > > > The benefit of this modelling is that you can introspect QEMU > > to discover what classes of channels support being yanked by > > this QEMU build, as well as what instances are configured to > > be yanked. ie you can distinguish between a QEMU that doesn't > > support yanking network devices, from a QEMU that does support > > yanking network devices, but doesn't have it enabled for any > > network device instances. > > This is true, though I think Lukas' suggestion with query-yank should be > as good in practice (you can't check before creating the NBD device > then, but would you actually want to do this?). > > And if all else fails, we can still add a few more feature flags to the > schema... > > Kevin -- Dr. David Alan Gilbert / dgilb...@redhat.com / Manchester, UK