* Stefano Garzarella (sgarz...@redhat.com) wrote: > On Fri, Mar 27, 2020 at 11:28:14AM +0000, Dr. David Alan Gilbert wrote: > > * Stefano Garzarella (sgarz...@redhat.com) wrote: > > > Hi Mao, > > > > > > On Fri, Mar 27, 2020 at 03:32:10PM +0800, Mao Zhongyi wrote: > > > > When running: > > > > (qemu) info migrate_parameters > > > > announce-initial: 50 ms > > > > announce-max: 550 ms > > > > announce-step: 100 ms > > > > compress-wait-thread: on > > > > ... > > > > max-bandwidth: 33554432 bytes/second > > > > downtime-limit: 300 milliseconds > > > > x-checkpoint-delay: 20000 > > > > ... > > > > xbzrle-cache-size: 67108864 > > > > > > > > add units for the parameters 'x-checkpoint-delay' and > > > > 'xbzrle-cache-size', it's easier to read. > > > > > > > > Signed-off-by: Mao Zhongyi <maozhon...@cmss.chinamobile.com> > > > > --- > > > > monitor/hmp-cmds.c | 4 ++-- > > > > 1 file changed, 2 insertions(+), 2 deletions(-) > > > > > > > > diff --git a/monitor/hmp-cmds.c b/monitor/hmp-cmds.c > > > > index 2a900a528a..8d22f96e57 100644 > > > > --- a/monitor/hmp-cmds.c > > > > +++ b/monitor/hmp-cmds.c > > > > @@ -440,7 +440,7 @@ void hmp_info_migrate_parameters(Monitor *mon, > > > > const QDict *qdict) > > > > MigrationParameter_str(MIGRATION_PARAMETER_DOWNTIME_LIMIT), > > > > params->downtime_limit); > > > > assert(params->has_x_checkpoint_delay); > > > > - monitor_printf(mon, "%s: %u\n", > > > > + monitor_printf(mon, "%s: %u" " milliseconds\n", > > > ^ > > > here we can remove the space and use a single string "%s: %u > > > milliseconds\n" > > > > Yes. > > > > > I've noticed that we use both ms or milliseconds, if you want to clean up > > > in a > > > separate patch, maybe we could use one of these everywhere. (I vote for > > > 'ms') > > > > I do prefer 'ms', however we do seem to just use milliseconds in > > info migrate > > IIUC, currently with 'info migrate_parameters' we have: > - announce-initial, announce-max, and announce-step with 'ms' > - downtime-limit with 'milliseconds'
You're right, so we do - in that case I agree, lets just move them all to 'ms'. Dave > Stefano > -- Dr. David Alan Gilbert / dgilb...@redhat.com / Manchester, UK