On 3/13/20 11:44 PM, Liran Alon wrote:
On 13/03/2020 22:07, Philippe Mathieu-Daudé wrote:
On 3/12/20 5:54 PM, Liran Alon wrote:
diff --git a/include/hw/i386/vmport.h b/include/hw/i386/vmport.h
index 34cc050b1ffa..aee809521aa0 100644
--- a/include/hw/i386/vmport.h
+++ b/include/hw/i386/vmport.h
@@ -12,6 +12,7 @@ typedef enum {
VMPORT_CMD_VMMOUSE_DATA = 39,
VMPORT_CMD_VMMOUSE_STATUS = 40,
VMPORT_CMD_VMMOUSE_COMMAND = 41,
+ VMPORT_CMD_GETHZ = 45,
Can you rename to something easier to read, such _GET_FREQS_HZ or nicer?
I actually prefer to stick with names similar to open-vm-tools. i.e.
Similar to the definitions in lib/include/backdoor_def.h.
This helps correlates a command in QEMU code to guest code (in
open-vm-tools) that interacts with it.
Well, we don't have to follow bad examples ;)
I can rename to just VMPORT_CMD_GET_HZ (Similar to what you suggested
for previous commands).
Thanks, this makes code review more easier.
But I don't have a strong opinion on this. If you still think
_GET_FREQ_HZ is preferred, I will rename to that.
-Liran