Vladimir Sementsov-Ogievskiy <vsement...@virtuozzo.com> writes: > Make kvmppc_hint_smt_possible hint append helper well formed: > switch errp paramter to Error *const * type, as it has uncommon > behavior: not change the pointer to return error, but operate on > already existent error object. > Rename function to be kvmppc_error_append_*_hint. > > Signed-off-by: Vladimir Sementsov-Ogievskiy <vsement...@virtuozzo.com> > Reviewed-by: Greg Kurz <gr...@kaod.org>
Let's adapt PATCH 03's commit message, like this: ppc: make Error **errp const where it is appropriate Mostly, Error ** is for returning error from the function, so the callee sets it. However kvmppc_hint_smt_possible gets already filled errp parameter. It doesn't change the pointer itself, only change the internal state of referenced Error object. So we can make it Error *const * errp, to stress the behavior. It will also help coccinelle script (in future) to distinguish such cases from common errp usage. While there, rename the function to kvmppc_error_append_smt_possible_hint(). With something like that: Reviewed-by: Markus Armbruster <arm...@redhat.com>