Hi On Tue, Nov 26, 2019 at 4:03 PM Felipe Franciosi <fel...@nutanix.com> wrote: > > Heya > > > On Nov 26, 2019, at 8:40 AM, Marc-André Lureau <marcandre.lur...@gmail.com> > > wrote: > > > > Hi > > > > On Mon, Nov 25, 2019 at 7:40 PM Felipe Franciosi <fel...@nutanix.com> wrote: > >> > >> Traditionally, the uint-specific property helpers only offer getters. > >> When adding object (or class) uint types, one must therefore use the > >> generic property helper if a setter is needed. > >> > >> This enhances the uint-specific property helper APIs by adding a > >> 'readonly' field and modifying all users of that API to set this > >> parameter to true. If 'readonly' is false, though, the helper will add > >> an automatic setter for the value. > >> > >> Signed-off-by: Felipe Franciosi <fel...@nutanix.com> > >> --- > >> hw/acpi/ich9.c | 4 +- > >> hw/acpi/pcihp.c | 6 +- > >> hw/acpi/piix4.c | 12 ++-- > >> hw/isa/lpc_ich9.c | 4 +- > >> hw/ppc/spapr_drc.c | 2 +- > >> include/qom/object.h | 28 +++++--- > >> qom/object.c | 152 ++++++++++++++++++++++++++++++++++++------- > >> ui/console.c | 3 +- > >> 8 files changed, 163 insertions(+), 48 deletions(-) > >> > >> diff --git a/hw/acpi/ich9.c b/hw/acpi/ich9.c > >> index 2034dd749e..94dc5147ce 100644 > >> --- a/hw/acpi/ich9.c > >> +++ b/hw/acpi/ich9.c > >> @@ -454,12 +454,12 @@ void ich9_pm_add_properties(Object *obj, > >> ICH9LPCPMRegs *pm, Error **errp) > >> pm->s4_val = 2; > >> > >> object_property_add_uint32_ptr(obj, ACPI_PM_PROP_PM_IO_BASE, > >> - &pm->pm_io_base, errp); > >> + &pm->pm_io_base, true, errp); > >> object_property_add(obj, ACPI_PM_PROP_GPE0_BLK, "uint32", > >> ich9_pm_get_gpe0_blk, > >> NULL, NULL, pm, NULL); > >> object_property_add_uint32_ptr(obj, ACPI_PM_PROP_GPE0_BLK_LEN, > >> - &gpe0_len, errp); > >> + &gpe0_len, true, errp); > >> object_property_add_bool(obj, "memory-hotplug-support", > >> ich9_pm_get_memory_hotplug_support, > >> ich9_pm_set_memory_hotplug_support, > >> diff --git a/hw/acpi/pcihp.c b/hw/acpi/pcihp.c > >> index 8413348a33..70bc1408e6 100644 > >> --- a/hw/acpi/pcihp.c > >> +++ b/hw/acpi/pcihp.c > >> @@ -80,7 +80,7 @@ static void *acpi_set_bsel(PCIBus *bus, void *opaque) > >> > >> *bus_bsel = (*bsel_alloc)++; > >> object_property_add_uint32_ptr(OBJECT(bus), ACPI_PCIHP_PROP_BSEL, > >> - bus_bsel, &error_abort); > >> + bus_bsel, true, &error_abort); > >> } > >> > >> return bsel_alloc; > >> @@ -373,9 +373,9 @@ void acpi_pcihp_init(Object *owner, AcpiPciHpState *s, > >> PCIBus *root_bus, > >> memory_region_add_subregion(address_space_io, s->io_base, &s->io); > >> > >> object_property_add_uint16_ptr(owner, ACPI_PCIHP_IO_BASE_PROP, > >> &s->io_base, > >> - &error_abort); > >> + true, &error_abort); > >> object_property_add_uint16_ptr(owner, ACPI_PCIHP_IO_LEN_PROP, > >> &s->io_len, > >> - &error_abort); > >> + true, &error_abort); > >> } > >> > >> const VMStateDescription vmstate_acpi_pcihp_pci_status = { > >> diff --git a/hw/acpi/piix4.c b/hw/acpi/piix4.c > >> index 93aec2dd2c..032ba11e62 100644 > >> --- a/hw/acpi/piix4.c > >> +++ b/hw/acpi/piix4.c > >> @@ -443,17 +443,17 @@ static void piix4_pm_add_propeties(PIIX4PMState *s) > >> static const uint16_t sci_int = 9; > >> > >> object_property_add_uint8_ptr(OBJECT(s), ACPI_PM_PROP_ACPI_ENABLE_CMD, > >> - &acpi_enable_cmd, NULL); > >> + &acpi_enable_cmd, true, NULL); > >> object_property_add_uint8_ptr(OBJECT(s), ACPI_PM_PROP_ACPI_DISABLE_CMD, > >> - &acpi_disable_cmd, NULL); > >> + &acpi_disable_cmd, true, NULL); > >> object_property_add_uint32_ptr(OBJECT(s), ACPI_PM_PROP_GPE0_BLK, > >> - &gpe0_blk, NULL); > >> + &gpe0_blk, true, NULL); > >> object_property_add_uint32_ptr(OBJECT(s), ACPI_PM_PROP_GPE0_BLK_LEN, > >> - &gpe0_blk_len, NULL); > >> + &gpe0_blk_len, true, NULL); > >> object_property_add_uint16_ptr(OBJECT(s), ACPI_PM_PROP_SCI_INT, > >> - &sci_int, NULL); > >> + &sci_int, true, NULL); > >> object_property_add_uint32_ptr(OBJECT(s), ACPI_PM_PROP_PM_IO_BASE, > >> - &s->io_base, NULL); > >> + &s->io_base, true, NULL); > >> } > >> > >> static void piix4_pm_realize(PCIDevice *dev, Error **errp) > >> diff --git a/hw/isa/lpc_ich9.c b/hw/isa/lpc_ich9.c > >> index 17c292e306..5555ce3342 100644 > >> --- a/hw/isa/lpc_ich9.c > >> +++ b/hw/isa/lpc_ich9.c > >> @@ -645,9 +645,9 @@ static void ich9_lpc_add_properties(ICH9LPCState *lpc) > >> ich9_lpc_get_sci_int, > >> NULL, NULL, NULL, NULL); > >> object_property_add_uint8_ptr(OBJECT(lpc), > >> ACPI_PM_PROP_ACPI_ENABLE_CMD, > >> - &acpi_enable_cmd, NULL); > >> + &acpi_enable_cmd, true, NULL); > >> object_property_add_uint8_ptr(OBJECT(lpc), > >> ACPI_PM_PROP_ACPI_DISABLE_CMD, > >> - &acpi_disable_cmd, NULL); > >> + &acpi_disable_cmd, true, NULL); > >> > >> ich9_pm_add_properties(OBJECT(lpc), &lpc->pm, NULL); > >> } > >> diff --git a/hw/ppc/spapr_drc.c b/hw/ppc/spapr_drc.c > >> index 62f1a42592..76f389f56a 100644 > >> --- a/hw/ppc/spapr_drc.c > >> +++ b/hw/ppc/spapr_drc.c > >> @@ -553,7 +553,7 @@ static void spapr_dr_connector_instance_init(Object > >> *obj) > >> SpaprDrc *drc = SPAPR_DR_CONNECTOR(obj); > >> SpaprDrcClass *drck = SPAPR_DR_CONNECTOR_GET_CLASS(drc); > >> > >> - object_property_add_uint32_ptr(obj, "id", &drc->id, NULL); > >> + object_property_add_uint32_ptr(obj, "id", &drc->id, true, NULL); > >> object_property_add(obj, "index", "uint32", prop_get_index, > >> NULL, NULL, NULL, NULL); > >> object_property_add(obj, "fdt", "struct", prop_get_fdt, > >> diff --git a/include/qom/object.h b/include/qom/object.h > >> index 128d00c77f..8fc28ed0c9 100644 > >> --- a/include/qom/object.h > >> +++ b/include/qom/object.h > >> @@ -1584,60 +1584,72 @@ void object_class_property_add_tm(ObjectClass > >> *klass, const char *name, > >> * @obj: the object to add a property to > >> * @name: the name of the property > >> * @v: pointer to value > >> + * @readonly: don't add setter for value > >> * @errp: if an error occurs, a pointer to an area to store the error > >> * > >> * Add an integer property in memory. This function will add a > >> * property of type 'uint8'. > >> */ > >> void object_property_add_uint8_ptr(Object *obj, const char *name, > >> - const uint8_t *v, Error **errp); > >> + const uint8_t *v, bool readonly, > >> + Error **errp); > >> void object_class_property_add_uint8_ptr(ObjectClass *klass, const char > >> *name, > >> - const uint8_t *v, Error **errp); > >> + const uint8_t *v, bool readonly, > >> + Error **errp); > > > > It would help readability and extensibility if we had an enum/bitflag: > > OBJECT_PROP_WRITABLE, OBJECT_PROP_READABLE (& OBJECT_PROP_READWRITE > > alias). > > I quite like your suggestion. When going through the various clients > of these, I found that many of them do not accept a zero value on the > setter. I didn't include them on this series, but if we had an > OBJ_PROP_REJECT_ZERO_VAL (or similar), we could take them in the > generic setters as well. Let me have a stab at that on the v2.
Hmm, that's a bit more involved. I would introduce min/max ranges instead. Let's not do that now. > > > > >> > >> /** > >> * object_property_add_uint16_ptr: > >> * @obj: the object to add a property to > >> * @name: the name of the property > >> * @v: pointer to value > >> + * @readonly: don't add setter for value > >> * @errp: if an error occurs, a pointer to an area to store the error > >> * > >> * Add an integer property in memory. This function will add a > >> * property of type 'uint16'. > >> */ > >> void object_property_add_uint16_ptr(Object *obj, const char *name, > >> - const uint16_t *v, Error **errp); > >> + const uint16_t *v, bool readonly, > >> + Error **errp); > >> void object_class_property_add_uint16_ptr(ObjectClass *klass, const char > >> *name, > >> - const uint16_t *v, Error > >> **errp); > >> + const uint16_t *v, bool > >> readonly, > >> + Error **errp); > >> > >> /** > >> * object_property_add_uint32_ptr: > >> * @obj: the object to add a property to > >> * @name: the name of the property > >> * @v: pointer to value > >> + * @readonly: don't add setter for value > >> * @errp: if an error occurs, a pointer to an area to store the error > >> * > >> * Add an integer property in memory. This function will add a > >> * property of type 'uint32'. > >> */ > >> void object_property_add_uint32_ptr(Object *obj, const char *name, > >> - const uint32_t *v, Error **errp); > >> + const uint32_t *v, bool readonly, > >> + Error **errp); > >> void object_class_property_add_uint32_ptr(ObjectClass *klass, const char > >> *name, > >> - const uint32_t *v, Error > >> **errp); > >> + const uint32_t *v, bool > >> readonly, > >> + Error **errp); > >> > >> /** > >> * object_property_add_uint64_ptr: > >> * @obj: the object to add a property to > >> * @name: the name of the property > >> * @v: pointer to value > >> + * @readonly: don't add setter for value > >> * @errp: if an error occurs, a pointer to an area to store the error > >> * > >> * Add an integer property in memory. This function will add a > >> * property of type 'uint64'. > >> */ > >> void object_property_add_uint64_ptr(Object *obj, const char *name, > >> - const uint64_t *v, Error **Errp); > >> + const uint64_t *v, bool readonly, > >> + Error **Errp); > >> void object_class_property_add_uint64_ptr(ObjectClass *klass, const char > >> *name, > >> - const uint64_t *v, Error > >> **Errp); > >> + const uint64_t *v, bool > >> readonly, > >> + Error **Errp); > >> > >> /** > >> * object_property_add_alias: > >> diff --git a/qom/object.c b/qom/object.c > >> index d51b57fba1..775f702465 100644 > >> --- a/qom/object.c > >> +++ b/qom/object.c > >> @@ -2326,6 +2326,26 @@ static void property_get_uint8_ptr(Object *obj, > >> Visitor *v, const char *name, > >> visit_type_uint8(v, name, &value, errp); > >> } > >> > >> +static void property_set_uint8_ptr(Object *obj, Visitor *v, const char > >> *name, > >> + void *opaque, Error **errp) > >> +{ > >> + uint8_t *field = opaque; > >> + uint8_t value; > >> + Error *local_err = NULL; > >> + > >> + visit_type_uint8(v, name, &value, &local_err); > >> + if (local_err) { > >> + goto err; > >> + } > >> + > >> + *field = value; > >> + > >> + return; > >> + > >> +err: > >> + error_propagate(errp, local_err); > >> +} > > > > > > This is probably going to be refactored once the auto error series > > land. But in the meantime, it would be nice to remove the goto label. > > I have just mimicked what other code does. Do you prefer the > error_propagate + return within the if()? I think I do. Ok, I didn't look at existing code. Up to you > > F. > > > > >> + > >> static void property_get_uint16_ptr(Object *obj, Visitor *v, const char > >> *name, > >> void *opaque, Error **errp) > >> { > >> @@ -2333,6 +2353,26 @@ static void property_get_uint16_ptr(Object *obj, > >> Visitor *v, const char *name, > >> visit_type_uint16(v, name, &value, errp); > >> } > >> > >> +static void property_set_uint16_ptr(Object *obj, Visitor *v, const char > >> *name, > >> + void *opaque, Error **errp) > >> +{ > >> + uint16_t *field = opaque; > >> + uint16_t value; > >> + Error *local_err = NULL; > >> + > >> + visit_type_uint16(v, name, &value, &local_err); > >> + if (local_err) { > >> + goto err; > >> + } > >> + > >> + *field = value; > >> + > >> + return; > >> + > >> +err: > >> + error_propagate(errp, local_err); > >> +} > >> + > > > > same > > > >> static void property_get_uint32_ptr(Object *obj, Visitor *v, const char > >> *name, > >> void *opaque, Error **errp) > >> { > >> @@ -2340,6 +2380,26 @@ static void property_get_uint32_ptr(Object *obj, > >> Visitor *v, const char *name, > >> visit_type_uint32(v, name, &value, errp); > >> } > >> > >> +static void property_set_uint32_ptr(Object *obj, Visitor *v, const char > >> *name, > >> + void *opaque, Error **errp) > >> +{ > >> + uint32_t *field = opaque; > >> + uint32_t value; > >> + Error *local_err = NULL; > >> + > >> + visit_type_uint32(v, name, &value, &local_err); > >> + if (local_err) { > >> + goto err; > >> + } > >> + > >> + *field = value; > >> + > >> + return; > >> + > >> +err: > >> + error_propagate(errp, local_err); > >> +} > > > > etc > > > >> + > >> static void property_get_uint64_ptr(Object *obj, Visitor *v, const char > >> *name, > >> void *opaque, Error **errp) > >> { > >> @@ -2347,60 +2407,104 @@ static void property_get_uint64_ptr(Object *obj, > >> Visitor *v, const char *name, > >> visit_type_uint64(v, name, &value, errp); > >> } > >> > >> +static void property_set_uint64_ptr(Object *obj, Visitor *v, const char > >> *name, > >> + void *opaque, Error **errp) > >> +{ > >> + uint64_t *field = opaque; > >> + uint64_t value; > >> + Error *local_err = NULL; > >> + > >> + visit_type_uint64(v, name, &value, &local_err); > >> + if (local_err) { > >> + goto err; > >> + } > >> + > >> + *field = value; > >> + > >> + return; > >> + > >> +err: > >> + error_propagate(errp, local_err); > >> +} > >> + > >> void object_property_add_uint8_ptr(Object *obj, const char *name, > >> - const uint8_t *v, Error **errp) > >> + const uint8_t *v, bool readonly, > >> + Error **errp) > >> { > >> - object_property_add(obj, name, "uint8", property_get_uint8_ptr, > >> - NULL, NULL, (void *)v, errp); > >> + object_property_add(obj, name, "uint8", > >> + property_get_uint8_ptr, > >> + readonly ? NULL : property_set_uint8_ptr, > >> + NULL, (void *)v, errp); > >> } > >> > >> void object_class_property_add_uint8_ptr(ObjectClass *klass, const char > >> *name, > >> - const uint8_t *v, Error **errp) > >> + const uint8_t *v, bool readonly, > >> + Error **errp) > >> { > >> - object_class_property_add(klass, name, "uint8", > >> property_get_uint8_ptr, > >> - NULL, NULL, (void *)v, errp); > >> + object_class_property_add(klass, name, "uint8", > >> + property_get_uint8_ptr, > >> + readonly ? NULL : property_set_uint8_ptr, > >> + NULL, (void *)v, errp); > >> } > >> > >> void object_property_add_uint16_ptr(Object *obj, const char *name, > >> - const uint16_t *v, Error **errp) > >> + const uint16_t *v, bool readonly, > >> + Error **errp) > >> { > >> - object_property_add(obj, name, "uint16", property_get_uint16_ptr, > >> - NULL, NULL, (void *)v, errp); > >> + object_property_add(obj, name, "uint16", > >> + property_get_uint16_ptr, > >> + readonly ? NULL : property_set_uint16_ptr, > >> + NULL, (void *)v, errp); > >> } > >> > >> void object_class_property_add_uint16_ptr(ObjectClass *klass, const char > >> *name, > >> - const uint16_t *v, Error **errp) > >> + const uint16_t *v, bool > >> readonly, > >> + Error **errp) > >> { > >> - object_class_property_add(klass, name, "uint16", > >> property_get_uint16_ptr, > >> - NULL, NULL, (void *)v, errp); > >> + object_class_property_add(klass, name, "uint16", > >> + property_get_uint16_ptr, > >> + readonly ? NULL : property_set_uint16_ptr, > >> + NULL, (void *)v, errp); > >> } > >> > >> void object_property_add_uint32_ptr(Object *obj, const char *name, > >> - const uint32_t *v, Error **errp) > >> + const uint32_t *v, bool readonly, > >> + Error **errp) > >> { > >> - object_property_add(obj, name, "uint32", property_get_uint32_ptr, > >> - NULL, NULL, (void *)v, errp); > >> + object_property_add(obj, name, "uint32", > >> + property_get_uint32_ptr, > >> + readonly ? NULL : property_set_uint32_ptr, > >> + NULL, (void *)v, errp); > >> } > >> > >> void object_class_property_add_uint32_ptr(ObjectClass *klass, const char > >> *name, > >> - const uint32_t *v, Error **errp) > >> + const uint32_t *v, bool > >> readonly, > >> + Error **errp) > >> { > >> - object_class_property_add(klass, name, "uint32", > >> property_get_uint32_ptr, > >> - NULL, NULL, (void *)v, errp); > >> + object_class_property_add(klass, name, "uint32", > >> + property_get_uint32_ptr, > >> + readonly ? NULL : property_set_uint32_ptr, > >> + NULL, (void *)v, errp); > >> } > >> > >> void object_property_add_uint64_ptr(Object *obj, const char *name, > >> - const uint64_t *v, Error **errp) > >> + const uint64_t *v, bool readonly, > >> + Error **errp) > >> { > >> - object_property_add(obj, name, "uint64", property_get_uint64_ptr, > >> - NULL, NULL, (void *)v, errp); > >> + object_property_add(obj, name, "uint64", > >> + property_get_uint64_ptr, > >> + property_set_uint64_ptr, > >> + NULL, (void *)v, errp); > >> } > >> > >> void object_class_property_add_uint64_ptr(ObjectClass *klass, const char > >> *name, > >> - const uint64_t *v, Error **errp) > >> + const uint64_t *v, bool > >> readonly, > >> + Error **errp) > >> { > >> - object_class_property_add(klass, name, "uint64", > >> property_get_uint64_ptr, > >> - NULL, NULL, (void *)v, errp); > >> + object_class_property_add(klass, name, "uint64", > >> + property_get_uint64_ptr, > >> + readonly ? NULL : property_set_uint64_ptr, > >> + NULL, (void *)v, errp); > >> } > >> > >> typedef struct { > >> diff --git a/ui/console.c b/ui/console.c > >> index 82d1ddac9c..3375c33d71 100644 > >> --- a/ui/console.c > >> +++ b/ui/console.c > >> @@ -1296,8 +1296,7 @@ static QemuConsole *new_console(DisplayState *ds, > >> console_type_t console_type, > >> object_property_allow_set_link, > >> OBJ_PROP_LINK_STRONG, > >> &error_abort); > >> - object_property_add_uint32_ptr(obj, "head", > >> - &s->head, &error_abort); > >> + object_property_add_uint32_ptr(obj, "head", &s->head, true, > >> &error_abort); > >> > >> if (!active_console || ((active_console->console_type != > >> GRAPHIC_CONSOLE) && > >> (console_type == GRAPHIC_CONSOLE))) { > >> -- > >> 2.20.1 > >> > > > > looks good otherwise > > > > > > -- > > Marc-André Lureau > -- Marc-André Lureau