On Mon, May 20, 2019 at 04:56:57PM -0600, Alex Williamson wrote:
> On Fri, 17 May 2019 14:58:16 +0200
> Jens Freimann <jfreim...@redhat.com> wrote:
> > Command line example:
> >
> > qemu-system-x86_64 -enable-kvm -m 3072 -smp 3 \
> > -machine q35,kernel-irqchip=split -cpu host \
> > -k fr \
> > -serial stdio \
> > -net none \
> > -qmp unix:/tmp/qmp.socket,server,nowait \
> > -monitor telnet:127.0.0.1:5555,server,nowait \
> > -device
pcie-root-port,id=root0,multifunction=on,chassis=0,addr=0xa \
> > -device pcie-root-port,id=root1,bus=pcie.0,chassis=1 \
> > -device pcie-root-port,id=root2,bus=pcie.0,chassis=2 \
> > -netdev
tap,script=/root/bin/bridge.sh,downscript=no,id=hostnet1,vhost=on \
> > -device
virtio-net-pci,netdev=hostnet1,id=net1,mac=52:54:00:6f:55:cc,bus=root2,failover=on
\
> > /root/rhel-guest-image-8.0-1781.x86_64.qcow2
> >
> > Then the primary device can be hotplugged via
> > (qemu) device_add
vfio-pci,host=5e:00.2,id=hostdev0,bus=root1,standby=net1
>
> Is this standby= option only valid for Network/Ethernet class code
> devices? If so, perhaps vfio-pci code should reject the option on
any
> non-ethernet devices. The option is also non-intuitive for users,
only
> through examples like above can we see it relates to the id of the
> secondary device. Could we instead name it something like
> "standby_net_failover_pair_id="?
It is only for ethernet (VFs), I will add code to reject
non-ethernet VF devices.
I agree the name is not descriptive and the one you suggest seems
good to
me.
>
> Also, this feature requires matching MAC addresses per the
description,
> where is that done? Is it the user's responsibility to set the
MAC on
> the host device prior to the device_add? If so, is this actually not
> only specific to ethernet devices, but ethernet VFs?
Yes, it's the users responsibility and the MACs are then matched by
the net_failover driver in the guest. It makes sense for ethernet
VFs only,
I'll add a check for that.