On Tue, Apr 19, 2011 at 01:42:00PM +0100, Peter Maydell wrote: > On 18 April 2011 22:00, Aurelien Jarno <aurel...@aurel32.net> wrote: > > > @@ -511,4 +530,11 @@ int floatx80_is_quiet_nan( floatx80 a1 ) > > return ( ( u.i.high & 0x7FFF ) == 0x7FFF ) && (uint64_t) ( u.i.low<<1 ); > > } > > > > +int floatx80_is_any_nan( floatx80 a1 ) > > +{ > > + floatx80u u; > > + u.f = a1; > > + return ((u.i.high & 0x7FFF) == 0x7FFF) && ( u.i.low<<1 ); > > +} > > + > > #endif > > As you can just see from the context, the new function is > actually identical to the existing floatx80_is_quiet_nan(), > but the latter is wrong, not this patch :-) > > Nobody seems to use floatx80_is_quiet_nan() so if we're just > going to nuke softfloat-native shortly there's no point fixing > it I guess. >
IIRC, we already discovered that when changing the name of the nan() functions. I also don't plan to fix it, it's one more reason to kill softfloat-native. -- Aurelien Jarno GPG: 1024D/F1BCDB73 aurel...@aurel32.net http://www.aurel32.net