Am 12.04.2011 11:27, schrieb Amit Shah: > Instead of using magic numbers, use structs that are more descriptive of > the fields being used. > > Signed-off-by: Amit Shah <amit.s...@redhat.com> > --- > hw/ide/core.c | 15 +++++++++++++-- > 1 files changed, 13 insertions(+), 2 deletions(-) > > diff --git a/hw/ide/core.c b/hw/ide/core.c > index c5913d8..fe50d8a 100644 > --- a/hw/ide/core.c > +++ b/hw/ide/core.c > @@ -1097,12 +1097,23 @@ static void > handle_get_event_status_notification(IDEState *s, > uint8_t *buf, > const uint8_t *packet) > { > + struct { > + uint8_t opcode; > + uint8_t polled; /* lsb bit is polled; others are reserved */ > + uint8_t reserved2[2]; > + uint8_t request;
Maybe class would be a better name? > + uint8_t reserved3[2]; > + uint8_t len_msb; > + uint8_t len_lsb; Why not a uint16_t length? > + uint8_t control; > + } __attribute__((packed)) *gesn_cdb; > unsigned int max_len, used_len; > > - max_len = ube16_to_cpu(packet + 7); > + gesn_cdb = (void *)packet; > + max_len = ube16_to_cpu(&gesn_cdb->len_msb); Instead of reading 16 bit from a 8 bit pointer, you could then use be16_to_cpu(gesn_cdb->length); > > /* It is fine by the MMC spec to not support async mode operations */ > - if (!(packet[1] & 0x01)) { /* asynchronous mode */ > + if (!(gesn_cdb->polled & 0x01)) { /* asynchronous mode */ > /* Only polling is supported, asynchronous mode is not. */ > ide_atapi_cmd_error(s, SENSE_ILLEGAL_REQUEST, > ASC_INV_FIELD_IN_CMD_PACKET); Kevin