v2: - improve the code left and right - Split better the zlib code - rename everything to v4.1 - Add tests for multifd-compress zlib - Parameter is now an enum (soon will see sztd)
ToDo: - Make operations for diferent methods: * multifd_prepare_send_none/zlib * multifd_send_none/zlib * multifd_recv_none/zlib - Use the MULTIFD_FLAG_ZLIB (it is unused so far). Please review and comment. v1: This series create compression code on top of multifd. It is still WIP, but it is already: - faster that current compression code - it does the minimum amount of copies possible - we allow support for other compression codes - it pass the multifd test sent in my previous series Test for existing code didn't work because code is too slow, I need to make downtime 10 times bigger to make it to converge on my test machine. This code works with same limits that multifd no- ToDo: - move printf's to traces - move code to a struct instead of if (zlib) inside the main threads. - improve error handling. Please, review and coment. Juan Quintela (8): migration: Fix migrate_set_parameter migration: fix multifd_recv event typo migration-test: rename parameter to parameter_int tests: Add migration multifd test migration-test: introduce functions to handle string parameters migration: Add multifd-compress parameter multifd: Add zlib compression support multifd: rest of zlib compression (WIP) hmp.c | 23 +++++- hw/core/qdev-properties.c | 11 +++ include/hw/qdev-properties.h | 1 + migration/migration.c | 25 ++++++ migration/migration.h | 1 + migration/ram.c | 140 +++++++++++++++++++++++++++++++-- migration/trace-events | 2 +- qapi/common.json | 15 ++++ qapi/migration.json | 19 ++++- tests/migration-test.c | 147 +++++++++++++++++++++++++++++------ 10 files changed, 348 insertions(+), 36 deletions(-) -- 2.20.1