* Wei Yang (richardw.y...@linux.intel.com) wrote: > subsection_found is true implies vmdesc is not NULL. > > This patch remove the additional check on vmdesc and rename > subsection_found to vmdesc_has_subsections to make it more self-explain. > > Signed-off-by: Wei Yang <richardw.y...@linux.intel.com>
Thanks, Reviewed-by: Dr. David Alan Gilbert <dgilb...@redhat.com> > > --- > v2: > * rename it to vmdesc_has_subsections > --- > migration/vmstate.c | 8 ++++---- > 1 file changed, 4 insertions(+), 4 deletions(-) > > diff --git a/migration/vmstate.c b/migration/vmstate.c > index e2bbb7b5f7..1305d1a528 100644 > --- a/migration/vmstate.c > +++ b/migration/vmstate.c > @@ -496,7 +496,7 @@ static int vmstate_subsection_save(QEMUFile *f, const > VMStateDescription *vmsd, > void *opaque, QJSON *vmdesc) > { > const VMStateDescription **sub = vmsd->subsections; > - bool subsection_found = false; > + bool vmdesc_has_subsections = false; > int ret = 0; > > trace_vmstate_subsection_save_top(vmsd->name); > @@ -508,9 +508,9 @@ static int vmstate_subsection_save(QEMUFile *f, const > VMStateDescription *vmsd, > trace_vmstate_subsection_save_loop(vmsd->name, vmsdsub->name); > if (vmdesc) { > /* Only create subsection array when we have any */ > - if (!subsection_found) { > + if (!vmdesc_has_subsections) { > json_start_array(vmdesc, "subsections"); > - subsection_found = true; > + vmdesc_has_subsections = true; > } > > json_start_object(vmdesc, NULL); > @@ -533,7 +533,7 @@ static int vmstate_subsection_save(QEMUFile *f, const > VMStateDescription *vmsd, > sub++; > } > > - if (vmdesc && subsection_found) { > + if (vmdesc_has_subsections) { > json_end_array(vmdesc); > } > > -- > 2.19.1 > -- Dr. David Alan Gilbert / dgilb...@redhat.com / Manchester, UK