The current internal meanings of "locked", "user_locked", "qmp_locked", "frozen", "enabled", and "disabled" are all a little muddled.
Deprecate the @status field in favor of two new booleans that carry very specific meanings. Then, rename and rework some of the internal semantics to help make the API a bit more clear and easier to read. Well, in my opinion. Based on my current bitmaps branch (includes Eric's patch and my documentation update patch.) John Snow (5): block/dirty-bitmap: add recording and busy properties block/dirty-bitmaps: rename frozen predicate helper block/dirty-bitmap: change semantics of enabled predicate block/dirty-bitmap: explicitly lock bitmaps with successors block/dirty-bitmaps: unify qmp_locked and user_locked calls block/dirty-bitmap.c | 74 +++++++++++++++++++--------------- blockdev.c | 18 ++++----- include/block/dirty-bitmap.h | 7 ++-- migration/block-dirty-bitmap.c | 8 ++-- nbd/server.c | 6 +-- qapi/block-core.json | 9 ++++- tests/qemu-iotests/236.out | 28 +++++++++++++ 7 files changed, 96 insertions(+), 54 deletions(-) -- 2.17.2