On 2018-12-03 16:32, Paolo Bonzini wrote: > From: Emanuele Giuseppe Esposito <e.emanuelegiuse...@gmail.com> > > Rename qpci_init_pc in qpci_pc_new and qpci_init_spapr in qpci_spapr_new, > since theese function actually allocate a new pci struct and initialize it.
Matter of taste, I guess ... I'd also be fine if we keep "init" instead of "new"... it's quite a bit of code churn ... > diff --git a/tests/libqos/pci-pc.h b/tests/libqos/pci-pc.h > index 491eeac..84cc300 100644 > --- a/tests/libqos/pci-pc.h > +++ b/tests/libqos/pci-pc.h > @@ -16,7 +16,14 @@ > #include "libqos/pci.h" > #include "libqos/malloc.h" > > -QPCIBus *qpci_init_pc(QTestState *qts, QGuestAllocator *alloc); > +/* qpci_new_pc(): > +* this function creates a new QPCIBusPC object, ... but please add at least a white space at the beginning of the above line. > + * and properly initialize its fields. > + * > + * returns the QPCIBus *bus field of a newly > + * allocated QPCIBusPC. > + */ > +QPCIBus *qpci_new_pc(QTestState *qts, QGuestAllocator *alloc); > void qpci_free_pc(QPCIBus *bus); I'd prefer to drop this patch, but if you want to keep it: Reviewed-by: Thomas Huth <th...@redhat.com>