On 2018-08-22 11:54, Juan Quintela wrote:
> So everythig is (a bit) more consistent
> 
> Signed-off-by: Juan Quintela <quint...@redhat.com>
> ---
>  tests/Makefile.include | 12 ++++--------
>  1 file changed, 4 insertions(+), 8 deletions(-)
[...]
> @@ -299,9 +297,7 @@ check-qtest-i386-y += tests/q35-test$(EXESUF)
>  check-qtest-i386-y += tests/vmgenid-test$(EXESUF)
>  gcov-files-i386-y += hw/pci-host/q35.c
>  check-qtest-i386-$(CONFIG_VHOST_USER_NET_TEST_i386) += 
> tests/vhost-user-test$(EXESUF)
> -ifeq ($(CONFIG_VHOST_USER_NET_TEST_i386),)
> -check-qtest-x86_64-$(CONFIG_VHOST_USER_NET_TEST_x86_64) += 
> tests/vhost-user-test$(EXESUF)
> -endif
> +check-qtest-x86_64-$(call lor, $(CONFIG_VHOST_USER_NET_TEST_i386), 
> $(CONFIG_VHOST_USER_NET_TEST_x86_64)) += tests/vhost-user-test$(EXESUF)

I think that is the wrong condition. It's rather "!i386 AND x86_64" that
you have to test here. Since that line will get incredibly long with the
$(call ...) expressions, I'd suggest to rather drop this hunk, I think
it's more readable the way it is.

 Thomas

Reply via email to