On Fri 10 Aug 2018 08:26:40 AM CEST, Leonid Bloch wrote: > Some refactoring for better readability is done here. > > Signed-off-by: Leonid Bloch <lbl...@janustech.com>
> - *l2_cache_entry_size = qemu_opt_get_size( > - opts, QCOW2_OPT_L2_CACHE_ENTRY_SIZE, s->cluster_size); > + *l2_cache_entry_size = qemu_opt_get_size(opts, > + QCOW2_OPT_L2_CACHE_ENTRY_SIZE, > + s->cluster_size); > - *refcount_cache_size = > - MIN(combined_cache_size, min_refcount_cache); > + *refcount_cache_size = MIN(combined_cache_size, > + min_refcount_cache); I won't oppose these changes if more people think that they improve readability, but it seems to me that this is just a matter of taste and there's no big difference either way. I'm personally fine with the way the code is now, and this coding style is used in many other parts of QEMU: $ git grep -A 1 '.* = .*($' $ git grep -A 1 '.* =$' Berto