On 13.02.2011, at 10:02, David Gibson wrote: > On Sat, Feb 12, 2011 at 04:37:46PM +0100, Alexander Graf wrote: >> On 12.02.2011, at 15:54, David Gibson wrote: > [snip] >>> +#define SDR_HTABORG_32 0xFFFF0000UL >>> +#define SDR_HTABMASK 0x000001FFUL >> >> Please mark this constant as ppc32 >> >>> + >>> +#if defined(TARGET_PPC64) >>> +#define SDR_HTABORG_64 0xFFFFFFFFFFFC0000ULL >>> +#define SDR_HTABSIZE 0x000000000000001FULL >> >> Please mark this constant as ppc64 > > Um.. I'm not sure what you mean by this.
Well, while to you SDR_HTABMASK and SDR_HTABSIZE are "obviously" meant for ppc32/ppc64 respectively, the average code reader won't know the difference. What I'm proposing is: #define SDR_32_HTABORG #define SDR_32_HTABMASK #define SDR_64_HTABORG #define SDR_64_HTABSIZE This way it's a lot more obvious that the two constants really belong to two completely different semantics :). Alex