Am 27.01.2018 um 03:05 hat John Snow geschrieben:
> This property will be used to opt-in to the new BlockJobs workflow
> that allows a tighter, more explicit control over transitions from
> one runstate to another.
> 
> Signed-off-by: John Snow <js...@redhat.com>

> diff --git a/include/block/blockjob.h b/include/block/blockjob.h
> index 00403d9482..b94d0c9fa6 100644
> --- a/include/block/blockjob.h
> +++ b/include/block/blockjob.h
> @@ -141,6 +141,11 @@ typedef struct BlockJob {
>       */
>      QEMUTimer sleep_timer;
>  
> +    /* Set to true when management API has requested 2.12+ job lifetime
> +     * management semantics.
> +     */
> +    bool manual;

Wouldn't it make more sense to describe what "2.12+ job lifetime
management semantics" actually are? Maybe then it would be easy to find
a more specific name, too, like manual_completion.

In fact, I wonder if the opposite flag wouldn't be nicer, i.e. having a
bool auto_completion (or finalization or whatever that extra step was
called in the final draft), defaulting to true.

Also, the comment style in this header is already pretty messed up, but
I think the styles that were originally meant to be used there, are

    /** this one for single lines */

    /**
     * and this one if things get a bit longer
     * and you need multiple lines.
     */

Kevin

Reply via email to