On 22.11.2017 23:05, Pierre Morel wrote: > Enhance the fault detection. > > Fixup the precedence to check the destination path existance > before checking for the source accessibility. > > Add the maxstbl entry to both the Query PCI Function Group > response and the PCIBusDevice structure. > > Initialize the maxstbl to 128 per default until we get > the actual data from the hardware. > > Signed-off-by: Pierre Morel <pmo...@linux.vnet.ibm.com> > Reviewed-by: Yi Min Zhao <zyi...@linux.vnet.ibm.com> > --- > hw/s390x/s390-pci-bus.h | 1 + > hw/s390x/s390-pci-inst.c | 63 > ++++++++++++++++++++++++++++++------------------ > hw/s390x/s390-pci-inst.h | 2 +- > 3 files changed, 41 insertions(+), 25 deletions(-) [...] > @@ -722,6 +733,10 @@ int pcistb_service_call(S390CPU *cpu, uint8_t r1, > uint8_t r3, uint64_t gaddr, > > setcc(cpu, ZPCI_PCI_LS_OK); > return 0; > + > +addressing_error: > + program_interrupt(env, PGM_SPECIFICATION, 6);
The label is called "addressing_error", but then you insert a PGM_SPECIFICTATION ? According to the name of the label, I'd rather expected a PGM_ADDRESSING here ... so maybe rename the label to "spec_error" or something similar? > + return 0; > } Thomas