Hi Eric, On Thu, Jan 26, 2017 at 2:49 PM, Eric Auger <eric.au...@redhat.com> wrote: > Rename KVM_DEV_ARM_VGIC_GRP_CPU_SYSREGS into KVM_DEV_ARM_VGIC_CPU_SYSREGS > as exposed in the kernel user API and pulled by update-linux-headers.sh.
I will fix it in my next qemu patch series. I have updated kernel to use KVM_DEV_ARM_VGIC_GRP_CPU_SYSREGS in latest kernel patch version v11. I so you can drop this patch. > > Signed-off-by: Eric Auger <eric.au...@redhat.com> > > --- > > KVM_DEV_ARM_VGIC_CPU_SYSREGS may be fixed at kernel level instead > --- > hw/intc/arm_gicv3_kvm.c | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/hw/intc/arm_gicv3_kvm.c b/hw/intc/arm_gicv3_kvm.c > index 267c2d6..d8ecbc3 100644 > --- a/hw/intc/arm_gicv3_kvm.c > +++ b/hw/intc/arm_gicv3_kvm.c > @@ -108,7 +108,7 @@ static inline void kvm_gicr_access(GICv3State *s, int > offset, int cpu, > static inline void kvm_gicc_access(GICv3State *s, uint64_t reg, int cpu, > uint64_t *val, bool write) > { > - kvm_device_access(s->dev_fd, KVM_DEV_ARM_VGIC_GRP_CPU_SYSREGS, > + kvm_device_access(s->dev_fd, KVM_DEV_ARM_VGIC_CPU_SYSREGS, > KVM_VGIC_ATTR(reg, s->cpu[cpu].gicr_typer), > val, write); > } > -- > 2.5.5 >