On 14/10/2016 20:33, Eric Blake wrote: > Also available as a tag at: > git fetch git://repo.or.cz/qemu/ericb.git nbd-zero-v7 > > v5 was here, but missed 2.7 freeze: > https://lists.gnu.org/archive/html/qemu-devel/2016-07/msg04053.html > > Since then, I've rebased the series, and the bulk of the changes > were to use consistent NBDFoo CamelCase naming, as well as to > improve the commit messages for questions raised on v5. > > v6 was here, with no human review yet: > https://lists.gnu.org/archive/html/qemu-devel/2016-10/msg03048.html > > Since then, I addressed the buildbot complaints.
The right place for the mingw-specific ESHUTDOWN is include/qemu/osdep.h. Queued with that change. Paolo > 001/16:[----] [--] 'nbd: Add qemu-nbd -D for human-readable description' > 002/16:[----] [--] 'nbd: Treat flags vs. command type as separate fields' > 003/16:[----] [--] 'nbd: Rename NBDRequest to NBDRequestData' > 004/16:[----] [--] 'nbd: Rename NbdClientSession to NBDClientSession' > 005/16:[----] [--] 'nbd: Rename struct nbd_request and nbd_reply' > 006/16:[----] [--] 'nbd: Share common reply-sending code in server' > 007/16:[----] [--] 'nbd: Send message along with server NBD_REP_ERR errors' > 008/16:[----] [--] 'nbd: Share common option-sending code in client' > 009/16:[----] [--] 'nbd: Let server know when client gives up negotiation' > 010/16:[----] [--] 'nbd: Let client skip portions of server reply' > 011/16:[----] [--] 'nbd: Less allocation during NBD_OPT_LIST' > 012/16:[----] [--] 'nbd: Support shorter handshake' > 013/16:[down] 'nbd: Refactor conversion to errno to silence checkpatch' > 014/16:[0012] [FC] 'nbd: Improve server handling of shutdown requests' > 015/16:[----] [--] 'nbd: Implement NBD_CMD_WRITE_ZEROES on server' > 016/16:[----] [--] 'nbd: Implement NBD_CMD_WRITE_ZEROES on client' > > Eric Blake (16): > nbd: Add qemu-nbd -D for human-readable description > nbd: Treat flags vs. command type as separate fields > nbd: Rename NBDRequest to NBDRequestData > nbd: Rename NbdClientSession to NBDClientSession > nbd: Rename struct nbd_request and nbd_reply > nbd: Share common reply-sending code in server > nbd: Send message along with server NBD_REP_ERR errors > nbd: Share common option-sending code in client > nbd: Let server know when client gives up negotiation > nbd: Let client skip portions of server reply > nbd: Less allocation during NBD_OPT_LIST > nbd: Support shorter handshake > nbd: Refactor conversion to errno to silence checkpatch > nbd: Improve server handling of shutdown requests > nbd: Implement NBD_CMD_WRITE_ZEROES on server > nbd: Implement NBD_CMD_WRITE_ZEROES on client > > block/nbd-client.h | 10 +- > include/block/nbd.h | 73 ++++++-- > nbd/nbd-internal.h | 12 +- > block/nbd-client.c | 96 ++++++---- > block/nbd.c | 8 +- > nbd/client.c | 510 > ++++++++++++++++++++++++++++------------------------ > nbd/server.c | 296 ++++++++++++++++++++---------- > qemu-nbd.c | 12 +- > qemu-nbd.texi | 5 +- > 9 files changed, 638 insertions(+), 384 deletions(-) >