On 06/01/2016 04:09 PM, Markus Armbruster wrote:
Cao jin <caoj.f...@cn.fujitsu.com> writes:

It has:
1. More newlines make the code block well separated.
2. Add more comments for msi_init.
3. Fix a indentation in vmxnet3.c.
4. ioh3420 & xio3130_downstream: put PCI Express capability init function
    together, make it more readable.

cc: Dmitry Fleytman <dmi...@daynix.com>
cc: Jason Wang <jasow...@redhat.com>
cc: Michael S. Tsirkin <m...@redhat.com>
cc: Markus Armbruster <arm...@redhat.com>
cc: Marcel Apfelbaum <mar...@redhat.com>

Reviewed-by: Marcel Apfelbaum <mar...@redhat.com>
Signed-off-by: Cao jin <caoj.f...@cn.fujitsu.com>
[...]
diff --git a/hw/pci/msi.c b/hw/pci/msi.c
index e0e64c2..97f35c0 100644
--- a/hw/pci/msi.c
+++ b/hw/pci/msi.c
@@ -165,6 +165,23 @@ bool msi_enabled(const PCIDevice *dev)
           PCI_MSI_FLAGS_ENABLE);
  }

+/*
+ * Make PCI device @dev MSI-capable.
+ * Non-zero @offset puts capability MSI at that offset in PCI config
+ * space.
+ * @nr_vectors is the number of MSI vectors (1, 2, 4, 8, 16 or 32).
+ * If @msi64bit, make the device capable of sending a 64-bit message
+ * address.
+ * If @msi_per_vector_mask, make the device support per-vector masking.
+ * @errp is for returning errors.

@errp only appears in PATCH 11.  The easiest fix is to add this comment
only then.


eh...sorry for my carelessness...

--
Yours Sincerely,

Cao jin



Reply via email to