On Wed, 05/11 13:41, Paolo Bonzini wrote: > diff --git a/include/sysemu/dma.h b/include/sysemu/dma.h > index b0fbb9b..ddc4afc 100644 > --- a/include/sysemu/dma.h > +++ b/include/sysemu/dma.h > @@ -197,14 +197,15 @@ void qemu_sglist_add(QEMUSGList *qsg, dma_addr_t base, > dma_addr_t len); > void qemu_sglist_destroy(QEMUSGList *qsg); > #endif > > -typedef BlockAIOCB *DMAIOFunc(BlockBackend *blk, int64_t sector_num, > +typedef BlockAIOCB *DMAIOFunc(int64_t sector_num, > QEMUIOVector *iov, int nb_sectors, > - BlockCompletionFunc *cb, void *opaque); > + BlockCompletionFunc *cb, void *cb_opaque, > + void *opaque); >
The patch itself looks good, but I'm wondering if it's time to introduce: typedef struct { BlockCompletionFunc *cb; void *opaque; } BlockCompletion; for more readability in such cases. Fam