Eric Blake <ebl...@redhat.com> writes:

> On 07/01/2015 02:22 PM, Markus Armbruster wrote:
>> Rename gen_marshal_input() to gen_marshal(), because the generated
>> function marshals both arguments and results.
>> 
>> Rename gen_visitor_input_containers_decl() to gen_marshal_vars(), and
>> move the other variable declarations there, too.
>> 
>> Rename gen_visitor_input_block()() to gen_marshal_input_visit(), and
>
> Double ().

Will fix.

>> rearrange its code slightly.
>> 
>> Rename gen_marshal_input_decl() to gen_marshal_proto(), because the
>> result isn't a full declaration, unlike gen_command_decl()'s.
>> 
>> New gen_marshal_decl() actually returns a full declaration.
>
> No change to generated code; good.
>
>> 
>> Signed-off-by: Markus Armbruster <arm...@redhat.com>
>> ---
>>  scripts/qapi-commands.py | 95 
>> ++++++++++++++++++++++--------------------------
>>  1 file changed, 43 insertions(+), 52 deletions(-)
>> 
>
>>      push_indent()
>> +
>> +    if rets:
>> +        # FIXME fishy: only pointers are initialized
>> +        if rets.c_null() == 'NULL':
>> +            retval = '%s retval = NULL;' % rets.c_type()
>> +        else:
>> +            retval = '%s retval;' % rets.c_type()
>
> May still need tweaking based on my earlier reviews.

Yes, this part should go away.

> Reviewed-by: Eric Blake <ebl...@redhat.com>

Thanks!

Reply via email to