On 03/17/2015 01:16 PM, John Snow wrote:

>> Other than that, I'm okay with a forward-declaration; if you want to
>> move it, but I'd be fine with moving the code, too.
>>
>> With _drive_backup() being called do_drive_backup():
>>
>> Reviewed-by: Max Reitz <mre...@redhat.com>
>>
> 
> Moving the code around might be better, it just makes for a much noisier
> patch. I made my decisions for v1 to keep code disturbed the least.
> 
> Once more critiques roll in I will decide what to do.

I like avoiding forward declarations for non-recursive static functions
(aka topological sorting); but if you do code motion, do it in a
separate patch from the other changes.

-- 
Eric Blake   eblake redhat com    +1-919-301-3266
Libvirt virtualization library http://libvirt.org

Attachment: signature.asc
Description: OpenPGP digital signature

Reply via email to