On 30/01/2015 19:41, John Snow wrote: > Add a simple DMA r/w test to ahci-test. > > Oh, and for the first 18 patches, refactor everything into helpers so > that each ahci_test isn't a thousand lines long. > > This patch depends upon the "ahci test preliminary refactoring" series > upstream, which shuffled a lot of libqos and malloc facilities to > support this series. > > This patchset is a necessary step in checking in AHCI/DMA migration > tests that I will later use as proof as suitability of enabling the > ICH9 and AHCI migration flags.
Sent a few comments, everything that I didn't reply to has my Reviewed-by. Paolo > John Snow (19): > libqos/ahci: Add ahci_port_select helper > libqos/ahci: Add ahci_port_clear helper > qtest/ahci: rename 'Command' to 'CommandHeader' > libqos/ahci: Add command header helpers > libqos/ahci: Add ahci_port_check_error helper > libqos/ahci: Add ahci_port_check_interrupts helper > libqos/ahci: Add port_check_nonbusy helper > libqos/ahci: Add cmd response sanity check helpers > qtest/ahci: Demagic ahci tests. > libqos/ahci: Add ide cmd properties > libqos/ahci: add ahci command functions > libqos/ahci: add ahci command verify > libqos/ahci: add ahci command size setters > libqos/ahci: Add ahci_guest_io > libqos/ahci: add ahci_io > libqos/ahci: Add ahci_clean_mem > qtest/ahci: Add a macro bootup routine > qtest/ahci: Assert sector size in identify test > qtest/ahci: Adding simple dma read-write test > > tests/ahci-test.c | 246 +++++++++------------- > tests/libqos/ahci.c | 554 > ++++++++++++++++++++++++++++++++++++++++++++++++++ > tests/libqos/ahci.h | 163 ++++++++++++--- > tests/libqos/malloc.c | 5 + > tests/libqos/malloc.h | 1 + > 5 files changed, 798 insertions(+), 171 deletions(-) >