Hello everyone, this is the third version of the Zynq GPIO model patch. It includes * mostly code cleanup (variable naming, removed unneeded casts, added some local vars for better readability) * moved zynq-gpio.h to include/hw/gpio * enhancement in the reset/init logic to ensure that reset sets the IRQ output lines to 0.
Regards, Colin Colin Leitner (2): zynq_gpio: GPIO model for Zynq SoC xilinx_zynq: Add zynq-gpio to the machine hw/arm/xilinx_zynq.c | 2 + hw/gpio/Makefile.objs | 1 + hw/gpio/zynq-gpio.c | 402 +++++++++++++++++++++++++++++++++++++++++++ include/hw/gpio/zynq-gpio.h | 79 +++++++++ 4 files changed, 484 insertions(+) create mode 100644 hw/gpio/zynq-gpio.c create mode 100644 include/hw/gpio/zynq-gpio.h -- 1.7.10.4