about naming:
We will need functions for set/unset a subregion of BdrvDirtyBitmap, to
fix migration and mirror (accordingly to my "[PATCH v2] block: fix
spoiling all dirty bitmaps by mirror and migration"). Having the
function 'bdrv_reset_dirty_bitmap' from this patch, we'll have to add
functions like
bdrv_set_dirty_bitmap_region and bdrv_reset_dirty_bitmap_region
But, may be, it is more consistent to have
bdrv_set_dirty_bitmap(BlockDriverState *bs, BdrvDirtyBitmap *bitmap, uint64_t
start, uint64_t count)
bdrv_reset_dirty_bitmap(BlockDriverState *bs, BdrvDirtyBitmap *bitmap, uint64_t
start, uint64_t count)
for more transparent access to underlaying hbitmap interface? And then,
name the considered function like 'bdrv_clear_dirty_bitmap'?
Best regards,
Vladimir
On 01.12.2014 23:30, John Snow wrote:
bdrv_reset_dirty_bitmap(BlockDriverState *bs, BdrvDirtyBitmap *bitmap)