On Fri, Oct 03, 2014 at 06:47:41PM +0100, Dr. David Alan Gilbert (git) wrote: > From: "Dr. David Alan Gilbert" <dgilb...@redhat.com> > > Add MIG_RPCOMM_REQPAGES command on Return path for the postcopy > destination to request a page from the source. > > Signed-off-by: Dr. David Alan Gilbert <dgilb...@redhat.com> > --- > include/migration/migration.h | 3 ++ > migration.c | 74 > +++++++++++++++++++++++++++++++++++++++++++ > 2 files changed, 77 insertions(+) > > diff --git a/include/migration/migration.h b/include/migration/migration.h > index cdd0e56..5e0d30d 100644 > --- a/include/migration/migration.h > +++ b/include/migration/migration.h > @@ -45,6 +45,7 @@ enum mig_rpcomm_cmd { > MIG_RPCOMM_INVALID = 0, /* Must be 0 */ > MIG_RPCOMM_SHUT, /* sibling will not send any more RP messages */ > MIG_RPCOMM_ACK, /* data (seq: be32 ) */ > + MIG_RPCOMM_REQPAGES, /* data (start: be64, len: be64) */ > MIG_RPCOMM_AFTERLASTVALID > }; > > @@ -250,6 +251,8 @@ void migrate_send_rp_shut(MigrationIncomingState *mis, > uint32_t value); > void migrate_send_rp_ack(MigrationIncomingState *mis, > uint32_t value); > +void migrate_send_rp_reqpages(MigrationIncomingState *mis, const char* > rbname, > + ram_addr_t start, ram_addr_t len); > > > void ram_control_before_iterate(QEMUFile *f, uint64_t flags); > diff --git a/migration.c b/migration.c > index 1731017..cfdaa52 100644 > --- a/migration.c > +++ b/migration.c > @@ -144,6 +144,38 @@ void migrate_send_rp_ack(MigrationIncomingState *mis, > migrate_send_rp_message(mis, MIG_RPCOMM_ACK, 4, (uint8_t *)&buf); > } > > +/* Request a range of pages from the source VM at the given > + * start address. > + * rbname: Name of the RAMBlock to request the page in, if NULL it's the > same > + * as the last request (a name must have been given previously) > + * Start: Address offset within the RB > + * Len: Length in bytes required - must be a multiple of pagesize > + */ > +void migrate_send_rp_reqpages(MigrationIncomingState *mis, const char > *rbname, > + ram_addr_t start, ram_addr_t len) > +{ > + uint8_t bufc[16+1+255]; /* start (8 byte), len (8 byte), rbname upto 256 > */ > + uint64_t *buf64 = (uint64_t *)bufc; > + size_t msglen = 16; /* start + len */ > + > + assert(!(len & 1)); > + if (rbname) { > + int rbname_len = strlen(rbname); > + assert(rbname_len < 256); > + > + len |= 1; /* Flag to say we've got a name */ > + bufc[msglen++] = rbname_len; > + memcpy(bufc + msglen, rbname, rbname_len); > + msglen += rbname_len; > + } > + > + buf64[0] = (uint64_t)start; > + buf64[0] = cpu_to_be64(buf64[0]);
I think this would be clearer as well as less verbose, as just: buf64[0] = cpu_to_be64(start); > + buf64[1] = (uint64_t)len; > + buf64[1] = cpu_to_be64(buf64[1]); > + migrate_send_rp_message(mis, MIG_RPCOMM_REQPAGES, msglen, bufc); > +} > + > void qemu_start_incoming_migration(const char *uri, Error **errp) > { > const char *p; > @@ -784,6 +816,17 @@ static void source_return_path_bad(MigrationState *s) > } > > /* > + * Process a request for pages received on the return path, > + * We're allowed to send more than requested (e.g. to round to our page size) > + * and we don't need to send pages that have already been sent. > + */ > +static void migrate_handle_rp_reqpages(MigrationState *ms, const char* > rbname, > + ram_addr_t start, ram_addr_t len) > +{ > + DPRINTF("migrate_handle_rp_reqpages: at %zx for len %zx", start, len); > +} > + > +/* > * Handles messages sent on the return path towards the source VM > * > */ > @@ -795,6 +838,8 @@ static void *source_return_path_thread(void *opaque) > const int max_len = 512; > uint8_t buf[max_len]; > uint32_t tmp32; > + uint64_t tmp64a, tmp64b; Hrm.. calling everything "tmp*" doesn't help readability. > + char *tmpstr; > int res; > > DPRINTF("RP: %s entry", __func__); > @@ -810,6 +855,11 @@ static void *source_return_path_thread(void *opaque) > expected_len = 4; > break; > > + case MIG_RPCOMM_REQPAGES: > + /* 16 byte start/len _possibly_ plus an id str */ > + expected_len = 16 + 256; > + break; > + > default: > error_report("RP: Received invalid cmd 0x%04x length 0x%04x", > header_com, header_len); > @@ -857,6 +907,30 @@ static void *source_return_path_thread(void *opaque) > atomic_xchg(&ms->rp_state.latest_ack, tmp32); > break; > > + case MIG_RPCOMM_REQPAGES: > + tmp64a = be64_to_cpup((uint64_t *)buf); /* Start */ > + tmp64b = be64_to_cpup(((uint64_t *)buf)+1); /* Len */ > + tmpstr = NULL; > + if (tmp64b & 1) { > + tmp64b -= 1; /* Remove the flag */ > + /* Now we expect an idstr */ > + tmp32 = buf[16]; /* Length of the following idstr */ > + tmpstr = (char *)&buf[17]; > + buf[17+tmp32] = '\0'; > + expected_len = 16+1+tmp32; > + } else { > + expected_len = 16; > + } > + if (header_len != expected_len) { > + error_report("RP: Received ReqPage with length %d expecting > %d", > + header_len, expected_len); > + source_return_path_bad(ms); > + } > + migrate_handle_rp_reqpages(ms, tmpstr, > + (ram_addr_t)tmp64a, > + (ram_addr_t)tmp64b); > + break; > + > default: > /* This shouldn't happen because we should catch this above */ > DPRINTF("RP: Bad header_com in dispatch"); -- David Gibson | I'll have my music baroque, and my code david AT gibson.dropbear.id.au | minimalist, thank you. NOT _the_ _other_ | _way_ _around_! http://www.ozlabs.org/~dgibson
pgpsOUY1AuwcM.pgp
Description: PGP signature