This patch series may require, and is based on another AHCI series pending on-list: http://lists.gnu.org/archive/html/qemu-devel/2014-10/msg04143.html
This series aims to improve the way that handle_cmd reads and behaves in interpreting the FIS packets received by the AHCI HBA. This series used to be part of a larger RFC, but has since been pared down to a more focused series. Previous RFC: http://lists.gnu.org/archive/html/qemu-devel/2014-09/msg02694.html Patch 1 is a subset of the previously posted "AHCI: Rename NCQFIS structure fields" patch. This subset is just aimed at improving the readability of the FIS decomposition in handle_cmd for now. Patch 2 is nearly the same as "AHCI: Fix FIS decomposition" which has yet to be reviewed. Patches 3, 4, and 5 have been inspected previously, and should be identical. "ide/ahci: Reorder error cases in handle_cmd" "ahci: Check cmd_fis[1] more explicitly" "ahci: factor out FIS decomposition" John Snow (5): ahci: add is_ncq predicate helper AHCI: Fix FIS decomposition ahci: Reorder error cases in handle_cmd ahci: Check cmd_fis[1] more explicitly ahci: factor out FIS decomposition from handle_cmd hw/ide/ahci.c | 233 ++++++++++++++++++++++++++++++---------------------------- hw/ide/ahci.h | 3 + 2 files changed, 125 insertions(+), 111 deletions(-) -- 1.9.3