These patches fix a couple of issues I noticed with the existing code in the ARM arm_excp_unmasked() function while I was reviewing the TrustZone series: * we currently try to use the same function for M profile and A/R profile, which makes both code paths harder to read (and maybe one day we'll implement what M actually does, in which case the two code paths will be totally divergent...) * accidental || vs && confusion in the conditionals governing VIRQ and VFIQ
I think they shouldn't conflict with the TZ patches except as minor textual conflicts. v1->v2 changes: * get the condition on VIRQ, VFIQ right (thanks to Edgar) Peter Maydell (2): target-arm: Separate out M profile cpu_exec_interrupt handling target-arm: Correct condition for taking VIRQ and VFIQ target-arm/cpu.c | 49 +++++++++++++++++++++++++++++++++++++++---------- target-arm/cpu.h | 20 ++++---------------- 2 files changed, 43 insertions(+), 26 deletions(-) -- 1.9.1