Hi, > > > > virtio-$device-{pci, s390, ccw} all duplicate the > > qdev properties of their virtio child. This approach does > > not work well with string or pointer properties since we > > must be careful about leaking or double-freeing them. > > > > Use the QOM alias property to forward property accesses to the > > VirtIORNG child. This way no duplication is necessary. > > > > For their child, object_initialize() leaves the object with a refcount of 1. > > object_property_add_child() adds its own reference which is dropped > > again when the property is deleted. > > > > The upshot of this is that we always have a refcount >= 1. Upon hot > > unplug the virtio-$device child is not finalized! > > > > Drop our reference after the child property has been added to the > > parent. > > > > Attention please: > > As Michael's comments, the patches will introduce regresion about > > "-device FOO,help", which had been fixed by my other patch series: > > [PATCH v2 0/7] add description field in ObjectProperty and PropertyInfo > struct > > http://lists.nongnu.org/archive/html/qemu-devel/2014-09/msg04908.html > > > > Acknowledgements: > > I copied Stefan's commit c5d49db message about virtio-blk which > > summarized reasons very well, I cannot agree more with him. > > Holp Stefan do not mind, thanks! > > > > Please review, Thanks a lot! > > Do you have a git branch for quick testing? > Sorry, I havn't. :(
I worked this in the environment of my company, then send patches. Would you apply those patches based qemu master by 'git am' ? Thanks! > > -Gonglei > > > > Gonglei (9): > > virtio-net: use aliases instead of duplicate qdev properties > > virtio: fix virtio-net child refcount in transports > > virtio/vhost scsi: use aliases instead of duplicate qdev properties > > virtio/vhost-scsi: fix virtio-scsi/vhost-scsi child refcount in > > transports > > virtio-serial: use aliases instead of duplicate qdev properties > > virtio-serial: fix virtio-serial child refcount in transports > > virtio-rng: use aliases instead of duplicate qdev properties > > virtio-rng: fix virtio-rng child refcount in transports > > virtio-balloon: fix virtio-balloon child refcount in transports > > > > hw/s390x/s390-virtio-bus.c | 16 ++++++++++------ > > hw/s390x/virtio-ccw.c | 18 +++++++++++------- > > hw/virtio/virtio-pci.c | 18 +++++++++++------- > > 3 files changed, 32 insertions(+), 20 deletions(-) > > One thing I noticed is that the various devices end up with similar > code in the end: > > object_initialize(&dev->vdev, sizeof(dev->vdev), TYPE_WHATEVER); > object_property_add_child(obj, "virtio-backend", OBJECT(&dev->vdev), > NULL); > object_unref(OBJECT(&dev->vdev)); > qdev_alias_all_properties(DEVICE(&dev->vdev), obj); > > Would it make sense to add a helper function for that? Yes. I think it make sense. Maybe I can add a helper function in virtio.c, named virtio_backend_init(). Agree? Thanks! Best regards, -Gonglei