Hi Anthony. Although I know that you're busy catching up the holidays, what's the status of this patch series? It looks like that you've committed patches which conflicts with it, so what can I do with this patch series to make your merge easier?
thanks, On Wed, Jan 06, 2010 at 11:39:24AM +0900, Isaku Yamahata wrote: > As Aurelien pointed out that piix smbus and apm aren't pc specific > because MIPS also uses it. So I renamed them. both file names and > symbol names. s/pc_smbus/pm_smbus/g, s/pc_apm/apm/g and so on. > > At first I tried s/pc_smbus/smbus/g, however smbus is already used. > So I chose pm_smbus. > > patch series description: > This is the preparation patch for q35 chipset and PCIE support. > > This patch series is for spliting out piix specific part from pc emulator > to make it easier to implement other pc chipset emulator. > Although my motivation is for 128+ PCI and another chipset support, > I think this patch series itself is good for readability and maintenance. > > thanks, > > Changes from V11: > - s/pc_smbus/pm_smbus/g, s/pc_apm/apm/g and so on > because it isn't pc specifc. mips also uses it. > - No logic changes. > > Changes from V10: > - pass DeviceState* to pc_smbus_init(), now info qtree shows smbus. > - change pci hotplug argument from void * to DeviceState*. > > Changes from V9: > - rebased 502e64fe23f19c086d42f6178cdda19e58996080 > - use qemu_irq to remove global variables, rtc_state > - make rtc_xxx functions accept/return ISADevice and related clean ups > - pci hot plug clean up > - removed #ifdef DEBUG patches. > > > Changes from V8: > - make rtc_xxx functions accept/return ISADevice. > - move up ioapic initalization patch. > - fixed up copyright notice. > > Changes from V7: > - rebased to fe0d61231eb6be6a83c54f4a2795f924ee963f8f > > Changes from v6: > - rebased to 731c54f86988d3f28268f184fabfe9b2a32fb5d3 > > Changes from v5: > - rebased 0.11.0-rc0 > - changed qemu_system_powerdown_register() to call > qemu_system_shutdown_request() if qemu_system_shutdown() is called before > registering. > > Changes from v4: > - fix version number. > - rebased anthony's staging tree whose latest change set is > 62969268f876c547ee64da6d60e0f363e0f1df75 > > Changes from v3: > - move qemu_system_powerdown() in vl.c and more generic > following the comment by Marcelo Tosatti <mtosa...@redhat.com> > acpi.c: make qemu_system_powerdown() piix independent. > - define cmos_set_s3_resume_init() and cmos_set_s3_resume() in pc.c > even if TARGET_I386 isn't defined following th ecommit by > Paolo Bonzini <bonz...@gnu.org> > pc.c: remove a global variable, RTCState *rtc_state. > - minor compilation fixes > > Changes from v2: > - clean up pc_pci_device_init() not to use unnecessary braces. > > Changes from v1: > - make patches full bisectable > - typo s/allocte/allocate/ > - some minor fixes > - dropped a merged patch > > Isaku Yamahata (27): > acpi: split out piix4 smbus routines from acpi.c into pm_smbus.c > acpi: split out apm register emulation from acpi.c > acpi: add acpi constants from linux header files and use them. > acpi: split acpi.c into the common part and the piix4 part. > acpi_piix4: remove unused variable in get_pmsts(). > pc: initialize ioapic before use. > pc, i440fx: Make smm enable/disable function i440fx independent. > pc: make an unnecessary global variable, pit, local. > pc: remove a global variable, floppy_controller. > pc: remove global variable rtc_state by using qemu_irq. > pc: introduce a function to allocate cpu irq. > pc: make pc_init1() not refer ferr_irq directly. > pc: split out cpu initialization from pc_init1() into pc_cpus_init(). > pc: split out memory allocation from pc_init1() into pc_memory_init() > pc: split out vga initialization from pc_init1() into pc_vga_init(). > pc: split out basic device init from pc_init1() into > pc_basic_device_init() > pc: split out pci device init from pc_init1() into > pc_pci_device_init() > pc: split out piix specific part from pc.c into pc_piix.c > pc: move rtc declarations from pc.h into a dedicated header file. > rtc: make rtc_xxx accept/return ISADevice instead of RTCState. > acpi_piix4: qdevfy. > pci hotplug: add argument to pci hot plug callback. > pci hotadd, acpi_piix4: remove global variables. > pm_smbus: remove #ifdef DEBUG. > acpi_piix4: remove #ifdef DEBUG. > apm: remove #ifdef DEBUG. > mc146818rtc: remove #ifdef DEBUG_CMOS. > > Makefile.target | 2 + > hw/acpi.c | 738 > +----------------------------------------------------- > hw/acpi.h | 78 ++++++ > hw/acpi_piix4.c | 596 +++++++++++++++++++++++++++++++++++++++++++ > hw/apm.c | 87 +++++++ > hw/apm.h | 22 ++ > hw/mc146818rtc.c | 44 ++-- > hw/mc146818rtc.h | 10 + > hw/mips_jazz.c | 1 + > hw/mips_malta.c | 6 +- > hw/mips_r4k.c | 3 +- > hw/pc.c | 350 ++++++++------------------ > hw/pc.h | 57 ++++- > hw/pc_piix.c | 250 ++++++++++++++++++ > hw/pci.c | 8 +- > hw/pci.h | 4 +- > hw/piix_pci.c | 5 +- > hw/pm_smbus.c | 181 +++++++++++++ > hw/pm_smbus.h | 21 ++ > hw/ppc_prep.c | 1 + > 20 files changed, 1440 insertions(+), 1024 deletions(-) > create mode 100644 hw/acpi.h > create mode 100644 hw/acpi_piix4.c > create mode 100644 hw/apm.c > create mode 100644 hw/apm.h > create mode 100644 hw/mc146818rtc.h > create mode 100644 hw/pc_piix.c > create mode 100644 hw/pm_smbus.c > create mode 100644 hw/pm_smbus.h > > > -- yamahata