On Tue, Jan 05, 2010 at 06:07:35PM +0200, Kirill A. Shutemov wrote: > On Tue, Jan 5, 2010 at 4:42 PM, Juan Quintela <quint...@trasno.org> wrote: > > "Kirill A. Shutemov" <kir...@shutemov.name> wrote: > >> CC usb-linux.o > >> cc1: warnings being treated as errors > >> usb-linux.c: In function 'usb_host_read_file': > >> usb-linux.c:1204: error: ignoring return value of 'fgets', declared with > >> attribute warn_unused_result > >> make: *** [usb-linux.o] Error 1 > >> > >> Signed-off-by: Kirill A. Shutemov <kir...@shutemov.name> > >> --- > >> usb-linux.c | 8 ++++++-- > >> 1 files changed, 6 insertions(+), 2 deletions(-) > >> > >> diff --git a/usb-linux.c b/usb-linux.c > >> index 88728e9..8673474 100644 > >> --- a/usb-linux.c > >> +++ b/usb-linux.c > >> @@ -1201,9 +1201,13 @@ static int usb_host_read_file(char *line, size_t > >> line_size, const char *device_f > >> device_file); > >> f = fopen(filename, "r"); > >> if (f) { > >> - fgets(line, line_size, f); > >> + if (fgets(line, line_size, f)) { > >> + ret = 1; > >> + } else { > >> + ret = 0; > >> + } > >> + > > This if is equivalent to: > > > > ret = !!fgets(line, line_size, f); > > > > No need for the if at all :) > > It's not very readable. > Probably better to use something like: > > ret = (fgets(line, line_size, f) != NULL); >
Might be matter of taste. E.g. I think !! is more readable than != NULL. And () around != are not needed. It's better to make code brief IMO, a lof of boilerplate hides bugs. Nothing to get hung about though. -- MST