On 03/10/2014 01:23 AM, Gerd Hoffmann wrote: > + if (guest_cursor) { > + x -= guest_x; > + y -= guest_y; > + guest_x += x; > + guest_y += y; > + dx = x; > + dy = y; > + }
Why write it in this funny way? Surely better as dx = x - guest_x; dy = y - guest_y; guest_x = x; guest_y = y; r~