On Thu, Mar 06, 2014 at 09:21:10PM -0700, Eric Blake wrote: > On 03/06/2014 05:40 PM, Marcelo Tosatti wrote: > > > > Failing initialization in case hugepage path has > > hugepage smaller than specified. > > > > Signed-off-by: Marcelo Tosatti <mtosa...@redhat.com> > > > > diff --git a/exec.c b/exec.c > > index b69fd29..c95a0f3 100644 > > --- a/exec.c > > +++ b/exec.c > > > }; > > > > +static QemuOptsList qemu_mempath_opts = { > > + .name = "mem-path", > > > - case QEMU_OPTION_mempath: > > - mem_path = optarg; > > + case QEMU_OPTION_mempath: { > > + opts = qemu_opts_parse(qemu_find_opts("mem-path"), optarg, > > 1); > > Pre-existing, but this is yet another inconsistent naming between C > objects and the command line. If we were consistent, it should be named > QEMU_OPTION_mem_path, and qemu_mem_path_options. (See my recent > complaint about other misnamed options: > https://lists.gnu.org/archive/html/qemu-devel/2014-03/msg01131.html)
Hi Erik, What is the practical effect of the mismatch?