On Mon, 03 Feb 2014 12:30:04 -0700 Eric Blake <ebl...@redhat.com> wrote:
> On 02/03/2014 08:57 AM, Igor Mammedov wrote: > > It will allow to reuse field with different BUSes, > > reducing code duplication. Field is intended for > > replacing 'hotplug_qdev' field in PCIBus and also > > will allow to avoid adding equivalent field to > > DimmBus with possiblitity to refactor other BUSes > > to use it instead of custom field. > > In addition once all users of allow_hotplug field > > are converted to new API, link could replace > > allow_hotplug field in qdev hotplug code. > > > > > +static inline void qbus_set_hotplug_handler(BusState *bus, DeviceState > > *handler, > > + Error **errp) > > +{ > > + object_property_set_link(OBJECT(bus), OBJECT(handler), > > + QDEV_HOTPLUG_HANDLER_PROPERTY, errp); > > + bus->allow_hotplug = 1; > > Should we convert allow_hotplug to bool over the course of this series? There isn't much point in touching it, since it's going to be removed once all hotplug-able buses are converted to new interface. > > -- > Eric Blake eblake redhat com +1-919-301-3266 > Libvirt virtualization library http://libvirt.org > -- Regards, Igor