This is an update and rebase of a patch set I sent at the beginning of September. If I get no comments on this round I'll just send a pull request next week.
r~ Richard Henderson (20): tcg-ia64: Use TCGMemOp within qemu_ldst routines tcg-ia64: Use shortcuts for nop insns tcg-ia64: Handle constant calls tcg-ia64: Simplify brcond tcg-ia64: Move AREG0 to R32 tcg-ia64: Avoid unnecessary stop bit in tcg_out_alu tcg-ia64: Use ADDS for small addition tcg-ia64: Use SUB_A3 and ADDS_A4 for subtraction tcg-ia64: Use A3 form of logical operations tcg-ia64: Introduce tcg_opc_mov_a tcg-ia64: Introduce tcg_opc_movi_a tcg-ia64: Introduce tcg_opc_ext_i tcg-ia64: Introduce tcg_opc_bswap64_i tcg-ia64: Re-bundle the tlb load tcg-ia64: Move bswap for store into tlb load tcg-ia64: Move tlb addend load into tlb read tcg-ia64: Reduce code duplication in tcg_out_qemu_ld tcg-ia64: Convert to new ldst helpers tcg-ia64: Move part of softmmu slow path out of line tcg-ia64: Optimize small arguments to exit_tb tcg/ia64/tcg-target.c | 1044 +++++++++++++++++++++++++++---------------------- tcg/ia64/tcg-target.h | 4 +- 2 files changed, 572 insertions(+), 476 deletions(-) -- 1.8.3.1