Il 21/08/2013 09:18, Lei Li ha scritto: > } else if (strstart(uri, "unix:", &p)) { > + if (s->enabled_capabilities[MIGRATION_CAPABILITY_LOCALHOST]) { > + local_start_outgoing_migration(s, p, &local_err); > + } > unix_start_outgoing_migration(s, p, &local_err); > } else if (strstart(uri, "fd:", &p)) { > fd_start_outgoing_migration(s, p, &local_err); > @@ -521,6 +524,15 @@ int migrate_use_xbzrle(void) > return s->enabled_capabilities[MIGRATION_CAPABILITY_XBZRLE]; > } > > +bool migrate_is_localhost(void) > +{ > + MigrationState *s; > + > + s = migrate_get_current(); > + > + return s->enabled_capabilities[MIGRATION_CAPABILITY_LOCALHOST]; > +}
I think this is a bad name, too. There is nothing more "local" in this migration than in "unix:" migration. Let's call the capability according to what it does, for example unix-page-flipping. Paolo