Il 09/08/2013 16:23, Alex Bligh ha scritto: > > On 9 Aug 2013, at 11:03, Paolo Bonzini wrote: > >>> >>> +/* New format calling conventions for timers */ >>> + >>> +/** >>> + * timer_free: >>> + * @ts: the timer >>> + * >>> + * Free a timer (it must not be on the active list) >>> + */ >>> +static inline void timer_free(QEMUTimer *ts) >>> +{ >>> + qemu_free_timer(ts); >>> +} >> >> If these functions have the same implementation, independent of ts's >> timerlist, let's just keep the qemu_*_timer names. > > I should probably explain the plan / rationale. > > Either you or Stefan (sorry, can't remember which) mentioned that > qemu_ as a prefix for functions (as opposed to QEMU as a prefix > for typedef structs) implied the function operated on a 'global' > basis. So in keeping with that I'm using qemu_timer_* for the > global names (i.e. the ones running on mainloop) and timer_* > for others (currently exactly one user in mainloop).
Yes. But in this case the mismatch would not hurt, right? > I want to move away from qemu_*_timer anyway (whether it's > to qemu_timer_* or timer_*) and indeed the automated patcher > needs that to be the case, or we can't support both versions > in the tree at once. > > If we don't want both, I would suggest using timer_* rather > than qemu_timer_*. This will reduce some of the line wrap > issues in the automated patch. Sure. Paolo